sir1

غیرفعال کردن Hotlink

9 پست در این موضوع قرار دارد

با سلام
حدود یکسال میشه که hotlink را غیرفعال کردم ولی در بعضی از تصاویر, همان تصویری که برای hotlink اپلود کردم را نشان می دهد.
مثلا در پست های زیر:
https://www.acgih.ir/electrical-safety-tips/

https://www.acgih.ir/burns-caused-by-electric/

لطفا راهنمایی کنید که چطوراین مورد را درست کنم

0

به اشتراک گذاری این پست


لینک به پست

سلام و درود

 

چطور توی سایت خودتون هم hotlink اعمال میشه؟

چطور hotlink رو فعال کرده بودید که الان غیرفعالش کردید؟

1

به اشتراک گذاری این پست


لینک به پست
در 32 دقیقه قبل، naghmesara گفته است :

سلام و درود

 

چطور توی سایت خودتون هم hotlink اعمال میشه؟

چطور hotlink رو فعال کرده بودید که الان غیرفعالش کردید؟

تو هاست از طریق hotlink protecttion فعال کردم. نمیدونم چرا اینطوریه برای سایت خودمم اعمال شده.

البته اینو بگم که حدود دو هفته میشه سایتو به https انتقال دادم.

کدی در htaccess برای ایجاد محدودیت وجود نداره. 

0

به اشتراک گذاری این پست


لینک به پست

درود مجدد

 

والا شواهد نشون میده که هات لینک فعاله.

محتوای فایل htaccess رو قرار بدید.

0

به اشتراک گذاری این پست


لینک به پست

بفرمایید:


# BEGIN rlrssslReallySimpleSSL rsssl_version[2.5.19]
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTPS} !=on [NC]
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
</IfModule>
# END rlrssslReallySimpleSSL
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
 <IfModule mod_deflate.c>
  # Compress HTML, CSS, JavaScript, Text, XML and fonts
  AddOutputFilterByType DEFLATE application/javascript
  AddOutputFilterByType DEFLATE application/rss+xml
  AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
  AddOutputFilterByType DEFLATE application/x-font
  AddOutputFilterByType DEFLATE application/x-font-opentype
  AddOutputFilterByType DEFLATE application/x-font-otf
  AddOutputFilterByType DEFLATE application/x-font-truetype
  AddOutputFilterByType DEFLATE application/x-font-ttf
  AddOutputFilterByType DEFLATE application/x-javascript
  AddOutputFilterByType DEFLATE application/xhtml+xml
  AddOutputFilterByType DEFLATE application/xml
  AddOutputFilterByType DEFLATE font/opentype
  AddOutputFilterByType DEFLATE font/otf
  AddOutputFilterByType DEFLATE font/ttf
  AddOutputFilterByType DEFLATE image/svg+xml
  AddOutputFilterByType DEFLATE image/x-icon
  AddOutputFilterByType DEFLATE text/css
  AddOutputFilterByType DEFLATE text/html
  AddOutputFilterByType DEFLATE text/javascript
  AddOutputFilterByType DEFLATE text/plain
  AddOutputFilterByType DEFLATE text/xml
  # Remove browser bugs (only needed for really old browsers)
  BrowserMatch ^Mozilla/4 gzip-only-text/html
  BrowserMatch ^Mozilla/4\.0[678] no-gzip
  BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
  Header append Vary User-Agent
</IfModule>
#Gzip
<ifmodule mod_deflate.c>
AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript
</ifmodule>
#End Gzip
## EXPIRES CACHING ##
ExpiresActive On
ExpiresByType image/jpg "access plus 1 year"
ExpiresByType image/jpeg "access plus 1 year"
ExpiresByType image/gif "access plus 1 year"
ExpiresByType image/png "access plus 1 year"
ExpiresByType text/css "access plus 1 month"
ExpiresByType application/x-javascript "access plus 2 month"
ExpiresByType text/javascript "access plus 2 month"
ExpiresByType application/javascript "access plus 2 month"
ExpiresByType application/pdf "access plus 1 month"
ExpiresByType application/x-shockwave-flash "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 year"
ExpiresByType image/icon "access plus 12 month"
ExpiresByType application/x-ico "access plus 12 month"
ExpiresByType application/ico "access plus 12 month"
## EXPIRES CACHING ##
<IfModule mod_headers.c>
    <FilesMatch "\.(bmp|css|flv|gif|ico|jpg|jpeg|js|pdf|png|svg|swf|tif|tiff)$">
        Header set Last-Modified "Tue, 31 Aug 2010 00:00:00 GMT"
    </FilesMatch>
</IfModule>
# BEGIN Turn ETags Off
<ifModule mod_headers.c>
  Header unset ETag
</ifModule>
FileETag None
# END Turn ETags Off
# BEGIN Remove Last-Modified Header
<ifModule mod_headers.c>
  Header unset Last-Modified
</ifModule>
# END Remove Last-Modified Header
Header unset Last-Modified
# to protect wp-config.php
<Files wp-config.php>
order allow,deny
deny from all
</Files>
# to protect the .htaccess file itself:
<Files .htaccess>
order deny,allow
deny from all
</Files>

<Files admin-ajax.php>
    Order allow,deny
    Allow from all
    Satisfy any
</Files>

 

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

درود مجدد

 

فعلا به این تغییرش بدید اگر مورد هات لینک درست شد باید دید مشکل از کدوم کد فایل htaccess اصلی هست.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

 

ویرایش شده در توسط naghmesara
2

به اشتراک گذاری این پست


لینک به پست
در 5 ساعت قبل، naghmesara گفته است :

درود مجدد

 

فعلا به این تغییرش بدید اگر مورد هات لینک درست شد باید دید مشکل از کدوم کد فایل htaccess اصلی هست.


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

 

همه کدارو  غیر از کد بالایی به صورت تستی برداشتم ولی درست نشد.

احتمالا اگه بدونیم که عکس 

http://www.acgih.ir/hotlink.jpg

 از کجا فراخوانی میشه و کدشو برداری درست میشه. ولی من هرچی فک میکنم غیر از htaccess برای هات لینک کدی را به فایل های دیگر اضافه نکردم.

الان هم که در سی پنل نگا کردم هات لینک غیرفعال است وهیچ کدی از اون داخل htaccess نیست پس قاعدتا باید هات لینک کار نکنه.

پشتیبان هاست هم میگه با هزینه برات اوکی میکنن. هر چی میگی میگه هزینه میگیرم

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

خب این آدرس شما یعنی داخل پوشه ها نیست

پس باید داخل پوشه www یا همون روت باشه، من اینطور شنیدم، یه نگاهی بندازید

ویرایش شده در توسط HONARDAD
1

به اشتراک گذاری این پست


لینک به پست
در 25 دقیقه قبل، HONARDAD گفته است :

خب این آدرس شما یعنی داخل پوشه ها نیست

پس باید داخل پوشه www یا همون روت باشه، من اینطور شنیدم، یه نگاهی بندازید

عکسش که داخل روت است ولی عکسم حذف میکنی باز خطای 404 برای عکس میده و مشکل با خذف عکس حل نمیشه

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری