8 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

سلام

پوسته Viper رو روی یک وردپرس لوکال نصب و ران کردم. این پوسته یک نوع پست سفارشی به نام product و تعدادی دسته مخصوص این نوع داره که میشه محصولات رو درش ثبت کرد.

برای نمایش اطلاعات هر محصول هم یک صفحه تک پست اختصاصی داره که از صفحه single سایر پست ها مجزاست.

مشکل اینه که این صفحه در حالت عادی لود نمیشه و خطای اتصال مرورگر میگیرم، و نه حتی 404.

کمی که با کدش ور رفتم متوجه شدم اگر تابع

the_content()

رو کامنت کنم، صفحه لود میشه و تایتل و بقیه جزییات هم بدون مشکل نمایش داده میشن. ولی برای نمایش متن پست وقتی تابع رو فعال میکنم صفحه لود نمیشه دیگه!

فقط هم اینجا این مشکل هست و بقیه پست ها درست نمایش داده میشن...

کسی میدونه مشکل از کجا میتونه باشه؟

قبلا متشکرم

ویرایش شده در توسط nses
0

به اشتراک گذاری این پست


لینک به پست

دقیقاً همه ی مراحل نصب رو طی کردید؟

افزونه ی Options Framework رو نصب کردید؟

3

به اشتراک گذاری این پست


لینک به پست

فریم ورک را نصب کردید و مشکل باقیست از صفحه ی لود نشده سورس کد بگیرید احتمالا ارورش در داخل لایه ای بازه که در صفحه دیده نمی شه

3

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

ممنون بابت پاسخ ها...

افزونه Options Framework نصب هست.

از صفحه لود نشده هم سورس میگیرم ولی چیز غیرعادی توش نیست! همه خطوط اجرا شده و جای خروجی تابع the_content خالی هست...

اینم کد فایل های single_products.php و content_products.php...


## single-products.php
<?php
/**
* The Template for displaying all single posts.
*
* @package web2feel
* @since web2feel 1.0
*/
get_header(); ?>
<div id="primary" class="content-area grid_9">
<div id="content" class="site-content" role="main">
<?php while ( have_posts() ) : the_post(); ?>
<?php get_template_part( 'content-products', 'single' ); ?>
<?php
// If comments are open or we have at least one comment, load up the comment template
if ( comments_open() || '0' != get_comments_number() )
comments_template( '', true );
?>
<?php endwhile; // end of the loop. ?>
</div><!-- #content .site-content -->
</div><!-- #primary .content-area -->
<?php get_sidebar(); ?>
<?php get_footer(); ?>


## content-products.php
<?php
/**
* @package web2feel
* @since web2feel 1.0
*/
?>
<article id="post-<?php the_ID(); ?>" <?php post_class('cf'); ?>>

<div class="product-single-top cf">
<div class="prod-image">
<?php
$thumb = get_post_thumbnail_id();
$img_url = wp_get_attachment_url( $thumb,'full' ); //get full URL to image (use "large" or "medium" if the images too big)
$image = aq_resize( $img_url, 220, 180, false ); //resize & crop the image
?>
<?php if($image) : ?> <a class="fancybox" href="<?php echo $img_url?>"><img src="<?php echo $image ?>"/></a> <?php endif; ?>
</div>

<header class="entry-header">
<h1 class="entry-title"><?php the_title(); ?></h1>
<div class="entry-meta">
<?php echo get_the_term_list( $post->ID, 'department', 'Department: ', ', ', '' ); ?>
</div><!-- .entry-meta -->
<p><?php echo get_post_meta($post->ID,'_product_info_product_description', true); ?></p>
<div class="the-price cf">
<h3>قیمت: <?php echo get_post_meta($post->ID,'_product_info_product_price', true); ?></h3>
<a href="<?php echo get_post_meta($post->ID,'_product_info_product_link', true); ?>" class="buy-button">خرید پستی </a>
</div>
</header><!-- .entry-header -->
</div>
<div class="product-single-bottom">

<div class="entry-content">
<?php the_content(); ?>
<?php wp_link_pages( array( 'before' => '<div class="page-links">' . __( 'Pages:', 'web2feel' ), 'after' => '</div>' ) ); ?>
</div><!-- .entry-content -->
</div>
</article><!-- #post-<?php the_ID(); ?> -->

سورس صفحه خطا رو هم ضمیمه کردم...

test.htm

ویرایش شده در توسط nses
0

به اشتراک گذاری این پست


لینک به پست

یک پیشنهاد یک شرط if, else برای حلقه تعریف کنید و متنی را در حالت else بخوانید تا از بابت اجرای صحیح کوئری مطمئن شوید

یعنی


<?php if (have_posts()) : ?>

را قبل از


<?php while (have_posts()) : the_post(); ?>

گذاشته و بعد ار


<?php endwhile; ?>

که من در این کدها پیدایش نکردم


<?php else : ?>
<div>مطلبی برای چاپ وجود ندارد </div>
<?php endif; ?>

را قرار دهید و چک کنید آیا این نوشته چاپ می شود یا نه اگر چاپ شد مشکل از بخش انتشار است و الا کدهای کامل این بخش باید بررسی شوند منظورم از مطرح شدن query تا ری ست شدنش است

3

به اشتراک گذاری این پست


لینک به پست

شرط رو هم گذاشتم و چیزی چاپ نشد. باز همون مشکل ...

خیلی بهش ور رفتم و کدها رو نگاه کردم، تا اونجا که من بلدم مشکل رو پیدا نکردم.

اگر از دوستان کسی بتونه این قالب رو تست کنه و عیب یابی کنه ممنون میشم. اگرچه میدونم احتمالا کار وقت گیر و زحمت آفرینی هست و انتظار چندانی ندارم.

.

در کل ممنونم بابت پاسخ ها...

0

به اشتراک گذاری این پست


لینک به پست

سلام

قالب را دوباره دریافت و نصب کنید من نصب کردم و هیچ مشکلی ندارد

عکس صفحه پروداکت:

post-336-0-63080200-1357770437_thumb.jpg

2

به اشتراک گذاری این پست


لینک به پست

سلام

قالب را دوباره دریافت و نصب کنید من نصب کردم و هیچ مشکلی ندارد

عکس صفحه پروداکت:

post-336-0-63080200-1357770437_thumb.jpg

سلام،

ممنونم واقعا بابت پاسخگویی فوق العاده تون،

مجددا دانلود و تست می کنم. امیدوارم مشکل برطرف بشه...

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط behnamstar
      سلام و عرض ادب
      من یه سایت وردپرسی دارم که به تازگی تغییر دامنه روش انجام دادم که بعد ازینکار مشکل عجیبی اتفاق افتاده 
      من دامنه ی https://damane1.co m رو ریدایرکت کردم به https://damane2.co m الان اتفاقی که میفته دامنه 1 ریدایرکت میشه روی دامنه 2 
      ولی زیر دامنه ها ریدایرکت نمیشن 
      مثلا روی این لینک کلیک بشه (https://damane1.co m/linksite) باید این لینک باز شه (https://damane2.co m/linksite)
      ولی این لینکها جدا جدا باز میشن 
      فقط دامنه https://damane1.co m روی https://damane2.co m ریدایرکت میشه بقیه ی لینک ها همه جدا جدا باز میشن.
      ممنون میشم از دوستان کمک کنن 
      حتی به هاست پشتیبانی هم تیکت دادم ولی متوجه مشکل نشدن.
    • توسط Timecity.ir
      سلام دوستان خسته نباشید . 
      من یک « پک فونت ایران سنس » خریداری کردم ، اما نمیدونم چجوری باید روی قالب وردپرس نصبش کنم .
      یه بار امتحان کردم سایت ارور مرگ صفحه سفید داد و با کلی تلاش تونستم آخرین بک آپی که داشتم رو اجرا کنم . 
      ممنون میشم اگه کسی راهنمایی کنه چجوری این فونت رو نصب کنم .
    • توسط abtahi16
      با سلام!
      من پوسته hestia رو نصب کردم، تصویر ها را روی موبایل خیلیاشو نشون نمیده.یعنی load نمیشه! ,ولی رو لپ تاپ اوکیه!
      ممنونم میشم کمکم کنین!
      لینک سایت: www.mehrejavdan.com
    • توسط nnmmss
      سلام
      من كاملا در وردپرس تازه كار هستم. سايتي با پوسته RealNews طراحي شده. منوهايي دارم كه داراي منو و زير منو هستند. وقتي يك نوشته را به زير منو اختصاص ميدم بعد روي منو ميروم كليه نوشته هاي زير منو را هم نشان ميدهد. مثلا من به اين صورت است
      منو1
      زيرمنو 1-1
      زير منو1-2
       
      من اگر روي زير منو 1-1 كليك كنم فقط نوشته هاي زير منو 1-1 را نشان ميده ولي وقتي روي منو1 كليك كنم تمام نوشته هاي منو1   ,    زيرمنو1-1 و زيرمنو1-2 را نشان ميدهد. چطور ميتوانم اين موضوع را تصحيح كنم كه با كليك كردن روي منو1 فقط نوشته مربوط به منو1 را نشان دهد
    • توسط rendesharif
      با سلام 
      24 ساعت پیش در حال آپدیت تب های وبسایت بودم که اینترنت قطع شد و هنگامی که سعی کردم دوباره وارد کنترل پنل بشم دیدم صفحات ساختار خودشون رو از دست دادن و به نحوی بصورت لایت بارگزاری میشن برای حل این مشکل چیکار میتونم بکنم آیا راه حلی هست.
      تصویر قسمت لاگین هم اضافه کردم میتونید ببینید که دیگه خبری از ساختار اصلی نیست در مابقی صفحات کنترل پنل هم به همین شکل هست