bijame

مشکل با فایل استایل

9 پست در این موضوع قرار دارد

دروود

من یه قالب دارم ، گاهی وقت ها فایل های style , rtl داخلش لود نمیشه 

یعنی همیشگی نیست ها اما گاهی وقت ها یهو اینجوری میشه یهو خراب میشه . 

این مشکل از چی می تونه باشه ، ممنون میشم راهنمایی کنید

0

به اشتراک گذاری این پست


لینک به پست
در 59 دقیقه قبل، bijame گفته است :

دروود

من یه قالب دارم ، گاهی وقت ها فایل های style , rtl داخلش لود نمیشه 

یعنی همیشگی نیست ها اما گاهی وقت ها یهو اینجوری میشه یهو خراب میشه . 

این مشکل از چی می تونه باشه ، ممنون میشم راهنمایی کنید

باسلام

به قالبتون برید و محتویات functions.php رو اینجا قرار بدید 

0

به اشتراک گذاری این پست


لینک به پست

سلام. چیز عجیبیه. به نظر میاد مربوط به افزونه های کش کردن باشه. اگر دارید غیرفعال کنید و ببینید بازم اون مشکل پیش میاد یا نه.

راه بررسی دیگه ای که به ذهنم میرسه اینه که با فایرفاکس سایت رو باز کنید و f12 رو بزنید تا اینسپکتور بیاد و بعد به تب Network برید و سایت رو رفرش کنید (یا ctrl +f5 )بزنید ببینید فایل rtl لود میشه براتون یا نه (موقعی که فایل راست چین لود نمیشه باید تست کنید.)

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

در در 11/29/2017 at 13:45، nazanin123 گفته است :

باسلام

به قالبتون برید و محتویات functions.php رو اینجا قرار بدید 

دروود ضمیمه شد

در در 11/29/2017 at 17:31، فرحان گفته است :

سلام. چیز عجیبیه. به نظر میاد مربوط به افزونه های کش کردن باشه. اگر دارید غیرفعال کنید و ببینید بازم اون مشکل پیش میاد یا نه.

راه بررسی دیگه ای که به ذهنم میرسه اینه که با فایرفاکس سایت رو باز کنید و f12 رو بزنید تا اینسپکتور بیاد و بعد به تب Network برید و سایت رو رفرش کنید (یا ctrl +f5 )بزنید ببینید فایل rtl لود میشه براتون یا نه (موقعی که فایل راست چین لود نمیشه باید تست کنید.)

دروود چک کردم نه فایل style لود میشه نه rtl

functions.php

ویرایش شده در توسط مهدی
0

به اشتراک گذاری این پست


لینک به پست

دوستان می شه خواهش کنم کمکم کنید واقعا هیچی پیدا نکردم :(

0

به اشتراک گذاری این پست


لینک به پست

افزونه های جانبی رو چطور غیرفعال کردین ببینید مشکل حل میشه یا نه ؟

0

به اشتراک گذاری این پست


لینک به پست
wp_enqueue_style('v_css', get_template_directory_uri().'/style.css','',null,'all');

حدس من اینه که مشکل از این کد باید باشه

بقیه هم نظر بدن.

در در 11/29/2017 at 13:45، nazanin123 گفته است :

به قالبتون برید و محتویات functions.php رو اینجا قرار بدید 

 

در در 11/29/2017 at 12:46، bijame گفته است :

این مشکل از چی می تونه باشه ، ممنون میشم راهنمایی کنید

 

0

به اشتراک گذاری این پست


لینک به پست
در 58 دقیقه قبل، yaali گفته است :

wp_enqueue_style('v_css', get_template_directory_uri().'/style.css','',null,'all');

حدس من اینه که مشکل از این کد باید باشه

بقیه هم نظر بدن.

 

 

باسلام ، وقتی تابع wp_head در header.php باشه دو دایرکتوری اصلی style.css و rtl.css با قراردادن کد زیر در فانکشنز در  head فراخوانی میشن

function mytheme_enqueue_style() {  
wp_enqueue_style( 'mytheme-style', get_stylesheet_uri() );
}
add_action( 'wp_enqueue_scripts', 'mytheme_enqueue_style' );
1

به اشتراک گذاری این پست


لینک به پست
در در 12/3/2017 at 19:54، nazanin123 گفته است :

باسلام ، وقتی تابع wp_head در header.php باشه دو دایرکتوری اصلی style.css و rtl.css با قراردادن کد زیر در فانکشنز در  head فراخوانی میشن


function mytheme_enqueue_style() {  
wp_enqueue_style( 'mytheme-style', get_stylesheet_uri() );
}
add_action( 'wp_enqueue_scripts', 'mytheme_enqueue_style' );

راستش من اومدم دوباره فایل ها رو فراخوانی کردم درست شد ، این روش رو هم تست می کنم ببینم این جواب بده فکر میکنم بهتر باشه

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری