farhad.in

مشکل در نمایش سطرها در کلاس wp_list_table

2 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

با سلام

 

دوستان با استفاده از کلاس wp_list_table وردپرس یک کلاس ساختم و از اون اکستندش کردم. طبق داکیومنت وردپرس جلو رفتم و متدهایی که لازم بود رو اورراید کردم و... .

الان مشکلم در نمایش سطرهای جدول هست، دقیق تر بخوام بگم متد display کلاس wp_list_table ...

بخش صفحه بندی رو درست نمایش میده ولی سطرها رو نه ... به تصویر زیر توجه کنید.

5a7c1e687b7a0_Screenshotfrom2018-02-0813-24-24.thumb.png.7512dd8cfe56c30eb3310c6a47da965d.png

مشکل از چی میتونه باشه ؟!

ویرایش شده در توسط farhad.in
0

به اشتراک گذاری این پست


لینک به پست

سایر کدها ...

$my_obj = new My_tbl();
$my_obj->prepare_items();
<div class="wrap">
  <h2>لیست</h2>
    <div id="poststuff">
        <div id="post-body" class="metabox-holder columns-10">
            <div id="post-body-content">
                <div class="meta-box-sortables ui-sortable">
                    <form method="get">
                        <?php
                        $my_obj->display(); 
                      ?>
                    </form>
                </div>
            </div>
        </div>
        <br class="clear">
    </div>
</div>

 

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط Ali#
      سلام.
      می خواهم هنگامی که مطالب از قسمت bulk actions (کارهای دسته جمعی)، ویرایش شد، به همه نوشته هایی که انتخاب شده و ویرایش شده اند یک برچسب اضافه شود.
      من این کد را نوشتم ولی مشکلی که دارد این است که فقط به یک پست، برچسب را اضافه می کند در حالی که من می خواهم به همه نوشته هایی که انتخاب شده بودند اضافه کند.
      این هم کد:
      add_action('bulk_edit_custom_box', 'bulk_test'); function bulk_test() { $post_ID = get_the_ID(); wp_set_post_tags($post_ID,'test',true ); } دوستان می دانم مشکل از $post_ID است که فقط یک آی دی را وارد می کند. ولی راه حل را پیدا نمی کنم.
      کسی می تواند راهنمایی کند؟