m4xs051

سفارشی کردن open graph

8 پست در این موضوع قرار دارد

سلام

قصد دارم open graph سایت رو سفارشی کنم. مثلا یه متن ثابتی بالای تمامی متا های اوپن گراف ست کنم. یعنی زمانیکه مقاله ای در تلگرام منتشر می شود قبل از اینکه لینک و توضیحات و عکس مقاله رو قرار بده اول متن ثابت باشه.

این فانکشن رو نوشتم ولی کار نمیکنه نمیدونم مشکل از کجاست. تو سورس سایت هست ولی زمانی که اشتراگ گذاشته میشه این تکست ثابت نمیاد!

add_action( 'wp_head', 'head_wbc_graph');
function head_wbc_graph(){
  echo '<meta property="og:determiner" content="متن تست برای بالای اوپن گراف" />';
};

 

0

به اشتراک گذاری این پست


لینک به پست

سلام

این‌طوری تست کن

add_action( 'wp_head', 'head_wbc_graph', 1 );

 

1

به اشتراک گذاری این پست


لینک به پست
در 1 ساعت قبل، مهدی گفته است :

سلام

این‌طوری تست کن


add_action( 'wp_head', 'head_wbc_graph', 1 );

 

سلام 

جواب نداد!

0

به اشتراک گذاری این پست


لینک به پست

سلام و درود

 

کدت درسته اون آخرین سیمیکالن کد که بعد از بسته شدن {} گذاشتی اضافه است البته تاثیری توی نتیجه کد نداره.

 

موفق باشی

1

به اشتراک گذاری این پست


لینک به پست
در 4 ساعت قبل، mehran-b گفته است :

سلام و درود

 

کدت درسته اون آخرین سیمیکالن کد که بعد از بسته شدن {} گذاشتی اضافه است البته تاثیری توی نتیجه کد نداره.

 

موفق باشی

ممنون 

آره متوجهش شدم. تشکر

ولی نمیدونم چرا خروجی نداره.

بنظرتون راه حل دیگری هست که تست کنم؟ در واقع میخوام این اپن گراف رو سفارشی کنم. یعنی یه سری کنم اضافه کنم-ترتیبشون رو مشخص کنم وغیره..

0

به اشتراک گذاری این پست


لینک به پست
در 1 دقیقه قبل، m4xs051 گفته است :

بنظرتون راه حل دیگری هست که تست کنم؟

نه دیگه همین باید کار کنه.

add_action('wp_head', function() {
	
	?>
	<meta property="og:determiner" content="متن تست برای بالای اوپن گراف" />
	<?php
	
});

شاید تابع wp_head رو توی header.php فراخوانی نکرده باشی.

1

به اشتراک گذاری این پست


لینک به پست
در 9 ساعت قبل، mehran-b گفته است :

نه دیگه همین باید کار کنه.


add_action('wp_head', function() {
	
	?>
	<meta property="og:determiner" content="متن تست برای بالای اوپن گراف" />
	<?php
	
});

شاید تابع wp_head رو توی header.php فراخوانی نکرده باشی.

متا داره تو قبل از </head> لود میشه.

ولی این کد کار نمیکنه. 

البته یه ابهام دیگری هم هست. بنظرتون ممکنه از نوع پراپرتی باشه که استفاده شده؟

0

به اشتراک گذاری این پست


لینک به پست
در 2 ساعت قبل، m4xs051 گفته است :

البته یه ابهام دیگری هم هست. بنظرتون ممکنه از نوع پراپرتی باشه که استفاده شده؟

نه مشکلی نیست اضافه میشه.

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری