• اطلاعیه ها

    • Saeed Fard

      آگهی استخدام برنامه نویس و پشتیبان وردپرس   13/12/95

      آگهی استخدام برنامه نویس و پشتیبان وردپرس
       
      2 نفر پشتیبان سایت وردپرسی
      ⁃ آشنا به برنامه نویسی قالب و پلاگین وردپرس 
      ⁃ توانایی راه اندازی سایت، قالب و افزونه های وردپرسی 
      ⁃ توانایی برنامه نویسی PHP در حد متوسط 
      ⁃ اطلاعات عمومی وب بالا 
      ⁃ توانایی پاسخگویی نوشتاری به سوالات انگلیسی با گرامر ساده 
      ⁃ آشنایی با HTML/CSS/jQuery 
      ⁃ دارای روحیه کار تیمی، خلاق، مسئولیت‌پذیر و پشتکار بالا ——— ۲ نفر برنامه نویس قالب وردپرس
      ⁃ تسلط به HTML/CSS/jQuery و Bootstrap
      ⁃ توانایی تبدیل HTML به قالب وردپرس
      ⁃ توانایی برنامه نویسی PHP و پلاگین نویسی وردپرس در حد متوسط
      ⁃ آشنایی به اصول سئو 
      ⁃ آشنایی با Git/subversion مزیت محسوب می‌شود.
      ⁃ دارای روحیه کار تیمی، خلاق، مسئولیت‌پذیر و پشتکار بالا ——— ۱ نفر طراح UI/UX
      ⁃ طراحی خلاقه وب سایت
      ⁃ طراحی با جدیدترین استایل‌های طراحی سایت
      ⁃ مسلط به تایپوگرافی انگلیسی و طراحی وب سایت انگلیسی
      ⁃ انتقاد پذیری و قبول بازخوردهای تیم و مشارکت با دیگر اعضاء تیم برای سرعت بخشیدن به فرایند انجام پروژه
      ⁃ آشنایی و درک HTML/CSS/jQuery
      ⁃ دارای روحیه کار تیمی، خلاق، مسئولیت‌پذیر و پشتکار بالا
      ⁃ امکان همکاری به صورت پروژه‌ای و دورکاری در این موقعیت شغلی فراهم است ——— مزایای کار در مجموعه گرودیا
      ⁃ تجربه ناب کار در سطح یک جهانی
      ⁃ محیط کار بسیار دوستانه و آرام
      ⁃ پرداخت های مناسب و سر وقت
      ⁃ کلاس های آموزشی داخلی به جهت بالا بردن دانایی و توانایی همه اعضا   از علاقه‌مندان و نیازمندان تقاضا می‌شود لطفا رزومه کاری خود را با قید موقعیت شغلی به ایمیل info@grodea.co ارسال نمایید.
    • Morteza

      سال 1396 خورشیدی مبارک   29/12/95

      سال 1396 خورشیدی مبارک
arman100000

ايا حجم فايل جي كوري بيش از نياز است ؟!

14 پست در این موضوع قرار دارد

دو تا فايل js توي قالبم لود ميشه

يكي از


ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js

يكي از


wp-includes/js/jquery/jquery.js

حجم هر كدوم نزديك به 100 كيلوبايت كه ميشه 200 كيلوبايت ! حجم كمي نيست

اولي رو براي منوي كشويي لود كردم (slideToggle) دومي رو براي اژاكس كردن صفحه هاي قبل و بعد !

اينم كد دومي


<script type="text/javascript" charset="utf-8">
jQuery(document).ready(function(){

jQuery('#postPagination a').live('click', function(e){
e.preventDefault();
var link = jQuery(this).attr('href');
jQuery('#content').fadeOut(700).load(link + ' #contentInner', function(){ jQuery('#content').fadeIn(700); });

});

});
</script>

احساس ميكنم براي اين دو تا كار ساده نياز به لود 200 كيلوبايت نيست و قسمت هايي از دو فايل مذكور اضافي هست ...

درسته ؟ اگه درسته راه حلش چيه ؟!

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

هر دو جی کوئری هستن اگر وردپرس شما نسخه آخر هست نیاز به فایل اول ندارید.

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

می تونی با کد زیر توی فانشن ، جی کوری پیشفرض رو حذف کنی


if (!is_admin()) {
function site_init()
{
// remove jQuery
wp_deregister_script('jquery');

}
add_action('init', 'site_init');
}

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

هر دو جی کوئری هستن اگر وردپرس شما نسخه آخر هست نیاز به فایل اول ندارید.

الان رو لوكاله قالب و وردپرسش 3.4 ه و بدون اين js گوگل كار نميده ! يعني بيارم رو سايت (3.5) ديگه نيازي به اون js گوگل نيست ؟

اين كد براي منوي كشويي هست


<script>
$(document).ready(function(){
$(".share").click(function(){
$(".sharein").slideToggle("slow");
});
});
</script>

كه بدون لود js گوگل كار نميكنه

می تونی با کد زیر توی فانشن ، جی کوری پیشفرض رو حذف کنی


if (!is_admin()) {
function site_init()
{
// remove jQuery
wp_deregister_script('jquery');

}
add_action('init', 'site_init');
}

اون فايل js رو خودم از قصد لود كردم

wp-includes/js/jquery/jquery.js

طبق يه آموزشي براي آژاكس كردن صفحه ها

ویرایش شده در توسط arman100000

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

من قبلا این مشکل رو داشتم ، با کد زیر ، آخرین ورژن جی کوری رو از سایت خودت لود کن ، بخش های وردپرس هم به خوبی باهاش کار می کنن


/** Remove local copy of jQuery */
if (!is_admin()) {
function site_init()
{
// remove jQuery
wp_deregister_script('jquery');
wp_register_script('jquery', ("http://site.com/style/js/jquery-1.7.2.min.js"), false, '1.7.2');
}
add_action('init', 'site_init');
}

آدرس جی کوری رو بهش بده ، دیگه نباید مشکلی به وجود بیاد ، نیازی هم به گوگل نداری ، ;)

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

من قبلا این مشکل رو داشتم ، با کد زیر ، آخرین ورژن جی کوری رو از سایت خودت لود کن ، بخش های وردپرس هم به خوبی باهاش کار می کنن


/** Remove local copy of jQuery */
if (!is_admin()) {
function site_init()
{
// remove jQuery
wp_deregister_script('jquery');
wp_register_script('jquery', ("http://site.com/style/js/jquery-1.7.2.min.js"), false, '1.7.2');
}
add_action('init', 'site_init');
}

آدرس جی کوری رو بهش بده ، دیگه نباید مشکلی به وجود بیاد ، نیازی هم به گوگل نداری ، ;)

اوه اوه :دي اقا من نفهميدم الان چي شد ! اگه ميشه يكم بيشتر توضيح بده از php و جي كوري تقريبا هيچي بلد نيستم ! ممنون ;)

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

جی کوری یه کتابخانه ی جاوا اسکریپت هست که توی سایت لود می شه و شما می تونی با کد های و توابعی که براش نوشته شده کارای بسیار جالبی انجام بدی .

حالا شما توی قالبت 2 تا فایل کتابخونه رو لود کردی که نیازی نیست ، شما بیا کلا کد گوگل رو حذف کن ، یا مثلا دانلودش کن ، بریز توی هاستت ، بعد از طریق کدی که بهت دادم ، ( کد رو باید توی function.php قالبت کپی کنی ) می یای ، ورژن های قبلی رو کاری می کنی که لود نشوند ، به جاش ورژنی که خودت آدرسش رو می دی لود میشه ، اگه سخت بود بگو تا ساده تر بگم ;)

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

تنك يو سو ماچ :دي

فقط اين اخري رو نگرفتم!

ورژن های قبلی رو کاری می کنی که لود نشوند ، به جاش ورژنی که خودت آدرسش رو می دی لود میشه ، اگه سخت بود بگو تا ساده تر بگم ;)

منظور از ورژن هاي قبلي چيه ؟!

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

خود وردپرس موقعی که بخواد جی کوری رو لود کنه ، یه ورژن (1.7) ، - مدام در حال آپدیت شدن هستند ، مثل نرم افزار - لود میکنه ، شما کاری می کنی که ورژنهای دیگه لود نشوند و اون ورژنی که خودت می خوای لود بشه ;)

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

من لود js گوگل رو با حذف تكه كدش قطع كردم و بعد اون كد رو مطابق با محل قرار گيري wp-includes/js/jquery/jquery.js در فانكشن قرار دادم اما تمام منو هاي كشويي از كار افتادن و كار نميكنن توي پوسته !

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

یک پیوند برای ی کوئری کافیه البته حذف تکه کد در اصل قضیه تغییری ایجاد نمی کنه

جی کوئری کتابخانه ی جاواست و وقتی ازش درخواستی می شه اون اجرا می کنه حالا شما هر دستور را از دوتاش می خوای و دستوراتت هم از جنس تاگل هستند چی می شه

یکی می بنده یکی هم همزمان باز می کنه در نتیجه حرکتی انجام نمی شه (همدیگه رو خنثی می کنند

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

خوب من كتابخانه گوگل رو حذف كردم بازم منوي كشويي كار نميكنه !

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

از متد پست 5 جی کوئری گوگل رو فراخوانی و جی کوئری وردپرس رو حذف کنید

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

واسه راحتی خیال و البته سرعت بالاتر می تونید جفتشون رو حذف کنید و این کد را اضافه کنید


<script src="http://code.jquery.com/jquery-latest.js"></script>

به اشتراک گذاری این پست


لینک به پست
به اشتراک گذاری در سایت های دیگر

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری