2 پست در این موضوع قرار دارد

سلام و عرض ادب و احترام

دوستان من یه مشکل غیر معمول و عجیب برخوردم من روی پوشه wp-includes  سایتم تمامی فایل های سایت رو از بیرون نمایش میداد به خاطر همین اومدم کد زیر را در htaccess  سایت قرار دادم البته این را هم اضافه کنم من خط کد RewriteEngine On را از کد زیر حذف کردم چون قبلا یک بار در فایل htaccess برای یک کد دیگری (انتقال 301 https  ) استفاده شده بود 

اگه بخواهم خلاصه بگم برای مخفی سازی پوشه wp-includes  از کد زیر استفاده کردم 

# Block the include-only files.
RewriteBase /
RewriteRule ^wp-admin/includes/ - [F,L]
RewriteRule !^wp-includes/ - [S=3]
RewriteRule ^wp-includes/[^/]+\.php$ - [F,L]
RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F,L]
RewriteRule ^wp-includes/theme-compat/ - [F,L]
Options All -Indexes

خصوصا این کد Options All -Indexes را هم انتها قرار دادم بعد اومدم داخل هاست یک فایل index.php  هم تو پوشه wp-includes  قرار دادم اما در کمال ناباوری دیدم وقتی این پوشه را تو مرورگر میزنم ارور نات فاند دریافت میکنم دوستان اگه راهکارمو کامل بخونید و ایراداشو بگیرید ممنون میشم خواهشا چند تا راهنمایی درست بکنید سپاس

0

به اشتراک گذاری این پست


لینک به پست

سلام

راهکار ساده تر هست، یک فایل index.php یا index.html خالی ایجاد کنید و درون پوشه wp-includes قرار بدید.

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری