pary_daryayi

مشكلات وب سايت من بعد از آپلود

16 پست در این موضوع قرار دارد

سلام دوستان.

من وب سايت آزمايشي مو آپلود كردم .

گاهي تو صفحه ي اولم css رو ميشناسه و گاهي نه .

و همين طور روي لينكها كه كليك ميكنم صفحات رو نميشناسه.

فكر ميكنم تو لوكال جايي مسير پيش فرض دادم كه الان نميدونم كجاست كه تغيير بدم .

ممنون ميشم راهنمايي كنيد.

http://blog.web-site-man.ir

مرسي

0

به اشتراک گذاری این پست


لینک به پست

زحمت نوشتن قالب رو خودتون کشیدید؟

اگر نه نام قالب رو بفرمایید

از طرف دیگه شما اینو گویا از لوکال به هاست منتقل کردید - که انتقالتون ایراد داره

3

به اشتراک گذاری این پست


لینک به پست

تمامی آدرس‌های فراخوانی شده در قالبتون روی لوکال قرار داره که میبایست آدرس سایت خودتون رو قرار بدید ،

مثال :


<link rel="stylesheet" href="http://localhost/new/wordpress/wp-content/themes/mb/style.css" type="text/css" media="screen" />

رو با :


<link rel="stylesheet" type="text/css" href="<?php bloginfo('template_directory'); ?>/style.css" />

تعویض کنید و بقیه هم به همین صورت ..

4

به اشتراک گذاری این پست


لینک به پست

زحمت نوشتن قالب رو خودتون کشیدید؟

اگر نه نام قالب رو بفرمایید

از طرف دیگه شما اینو گویا از لوکال به هاست منتقل کردید - که انتقالتون ایراد داره

بله , يه قالب ساده هستش كه خودم ايجاد كردم

درسته از لوكال منتقل كردم . الان براي اصلاحش بايد چكار كنم ؟

تمامی آدرس‌های فراخوانی شده در قالبتون روی لوکال قرار داره که میبایست آدرس سایت خودتون رو قرار بدید ،

روي لوكال كه بود , به همين شكل دوم كه شما نوشتيد , نوشتم , البته از directory استفاده نكردم - تست ميكنم


<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
<script src="<?php bloginfo('template_url'); ?>/js/jquery-1.8.2.js" language="javascript" type="text/javascript"></script>

0

به اشتراک گذاری این پست


لینک به پست

كد شما رو امتحان كردم آقا سعيد ولي درست نشد.

اين كد داره مسيري كه روي لوكال بود رو نشون ميده . پس يعني جايي اين مسير ذخيره شده . ولي نميدونم كجا كه تغييرش بدم.


<link rel="stylesheet" href="http://localhost/new/wordpress/wp-content/themes/mb/style.css" type="text/css" media="screen" />

ممنون

0

به اشتراک گذاری این پست


لینک به پست

ببینید


http://localhost/new/wordpress

اصلا نباید در آدرس‌هاتون باشه ، این از روی سرور لوکال‌هاست ویندوزتون لود میکنه به همین دلیل در وب مشکل ایجاد شده ، باید این آدرس جایگزین آدرس سایتتون بشه به این صورت :


<link rel="stylesheet" href="http://blog.web-site-man.ir/wp-content/themes/mb/style.css" type="text/css" media="screen" />

میتونید فایل‌ هدر رو اینجا پیوست کنید تا براتون درست کنیم ..

5

به اشتراک گذاری این پست


لینک به پست

وقتي روي لوكال بودم تو قسمت تنظيمات مديريت اين رو وارد كرده بودم :


http://localhost/new/wordpress

اينو تو پايگاه در جدول wp_option پيدا كردم و site_url رو آدرس سايتم قرار دادم و الان css رو ميشناسه (علت اينكه تو پايگاه تغيير دادم اين بود كه فعلا وارد صفحه ي مديريت نميشه)

ولي لينك ها رو نه .. يعني مسير بالا جايي براي لينك هم ذخيره شده كه اونو هرچي تو پايگاه جستجو كردم پيدا نكردم.

تو فايل هدر اينا رو دارم كه الان ديگه مشكل css و jquery نيست . مشكل لينك ها وجود داره .


<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
<script src="<?php bloginfo('template_url'); ?>/js/jquery-1.8.2.js" language="javascript" type="text/javascript"></script>
<script src="<?php bloginfo('template_url'); ?>/js/left-corner.js" language="javascript" type="text/javascript"></script>
<script src="<?php bloginfo('template_url'); ?>/js/backtotop.js" language="javascript" type="text/javascript"></script>

0

به اشتراک گذاری این پست


لینک به پست

دوستان ممنونم , تا حدودي حل شد ؛ تونستم با تغيير در پايگاه به مديريت برم و جاهايي كه مسير لوكال داده بودم رو با مسير سايتم جايگزين كنم.

الان فقط ابزارك هاي بايگاني و دسته ها درست كار نميكنن .

ممنون ميشم علت اين رو بگيد.

------------------------

پ.ن : ميدونيد تو وردپرس تازه كارم , با جستجو هم هميشه به نتيجه نميرسم .

0

به اشتراک گذاری این پست


لینک به پست

الان که لینک ها رو درست کردید - پیوندهای یکتا رو هم یه بار بروز کنید

2

به اشتراک گذاری این پست


لینک به پست

بروز كردم ولي همچنان برچسب , بايگا ني , دسته ها درست كار نميكنند و با كليك بر اونها فقط هدر نمايش داده ميشه.

0

به اشتراک گذاری این پست


لینک به پست

فایل های آرشیوی و دسته ها رو درست نوشتید؟

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

ممنونم . ولي من تو آموزشها ديدم كه ميتونيم فقط اين فايل ها رو داشته باشيم :

index.php ؛ header.php ؛ footer.php ؛ sidebar.php ؛ comments.php و function.php

به خاطر همين من archive.php و category.php ايجاد نكردم.

يك كد فعال سازي ابزارك در function گذاشتم و يك كد در sidebar .

يك تابع تاريخ هم گذاشته بودم كه چون مشكل ايجاد كرده بود فعلا حذفش كردم و لينك ها" دسته " , " بايگاني " و ... كار ميكنند اما بصورت بهم ريخته.

ببينيد لطفا :

http://blog.web-site-man.ir

خيلي ممنونم .

ویرایش شده در توسط pary_daryayi
0

به اشتراک گذاری این پست


لینک به پست

دوستان ممنونم , فهميدم مشكل از كجا بود ؛ فعلا اين مورد هم حل شد .

0

به اشتراک گذاری این پست


لینک به پست

سلام.

من بعد از اينكه قالب رو تغيير دادم يك مشكل پيش اومد . با اينكه نسخه ي 1.8.2 جي كوئري درست آپلود شده , اما اونو نميشناسه . اگر view - source رو ببينيد , متوجه ميشيد كه اصلا اين فايل js رو نميخونه , به خاطر همين هرجا از جي كوئري استفاده كردم , بي فايده هست.

ميشه بگيد علت چيه ؟

0

به اشتراک گذاری این پست


لینک به پست

باید آدرس دهی رو طبق وردپرس انجام بدید.

نمونه

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

ممنونم . من هم به همين صورت آدرس دهي كرده بودم.

نام پوشه رو عوض كردم , دوباره فايل هاي js رو آپلود كردم , درست شد.

ویرایش شده در توسط pary_daryayi
0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری