runy

اجرا نکردن کد HTMLدر متن مطلب(قسمت کد )

14 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

سلام

من یه فایل فلش ساختم و با HTML سیو کردم و بعد فایل SWF را آپ کردم و آدرس فایل را در کد HTML قارا دادم و متن کد را در قسمت متن نوشته کنار دیدیاری جایی که میشه کد نویسی کرد گذاشتم ولی فایل فلشم را اجرا نمیکنه در حالت معمولی اجرا میشه ولی در وردپرس اجرا نمیشه

چرا؟

لینک مطلبی که توش کد فلشه را قرار دادم

http://nedaj.ir/blog/1391/11/10/140/

اینم کدشه


<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/html40/loose.dtd">
<html>
<head>
<title></title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="author" content="Runy">
<meta name="generator" content="SWiSH Max3 (2009.11.30) www.swishzone.com">
<meta name="description" content="">
<!-- Created by SWiSH Max3 - The Ultimate Flash Creation Tools - www.swishzone.com -->
<style type="text/css">
/*<![CDATA[*/
html, body
{
margin: 0;
padding: 0;
height: 100%;
}
object
{
vertical-align: top;
}
/*]]>*/
</style>
</head>
<body bgcolor="#FFFFFF">
<center>
<object
classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0"
id="Aazam"
width="410" height="390"
>
<param name="movie" value="http://ferasat.persiangig.com/neda/Files/Aazam.swf">
<param name="bgcolor" value="#FFFFFF">
<param name="quality" value="high">
<param name="seamlesstabbing" value="false">
<param name="allowscriptaccess" value="samedomain">
<embed
type="application/x-shockwave-flash"
pluginspage="http://www.adobe.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"
name="Aazam"
width="410" height="390"
src="Aazam.swf"
bgcolor="#FFFFFF"
quality="high"
seamlesstabbing="false"
allowscriptaccess="samedomain"
>
<noembed>
</noembed>
</embed>
</object>
</center>
</body>
</html>

(اگر سوالم ناشیانه است نخندید من برنامه کار نکردم دانشجوی فیزیکم و سرم تو فرموله )

ویرایش شده در توسط runy
0

به اشتراک گذاری این پست


لینک به پست

چون خاصیت src="Aazam.swf" رو آدرس دهی مستقیم نکردید.

3

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

چون خاصیت src="Aazam.swf" رو آدرس دهی مستقیم نکردید.

یعنی چی ؟ باید در هاست در شاخه اصلی بریزم و بجای


value="http://ferasat.persiangig.com/neda/Files/Aazam.swf"

کدی که گفتید را بدم؟ ولی کردم نشدا

اصلا برای نمایش یه فایل فلش در یک پست باید چه کار کرد؟

ویرایش شده در توسط runy
0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

یعنی چی ؟ باید در هاست در شاخه اصلی بریزم و بجای


value="http://ferasat.persiangig.com/neda/Files/Aazam.swf"

کدی که گفتید را بدم؟ ولی کردم نشدا

اصلا برای نمایش یه فایل فلش در یک پست باید چه کار کرد؟

<embed width="256" height="200" src="http://ferasat.persiangig.com/neda/Files/Aazam.swf">

اینو امتحان کن

ویرایش شده در توسط javad abbasi
3

به اشتراک گذاری این پست


لینک به پست

<embed width="256" height="200" src="http://ferasat.persiangig.com/neda/Files/Aazam.swf">

اینو امتحان کن

نشد نمایش نمیده

افزونه ای ندارید برای نمایش فلش در پست؟

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

نشد نمایش نمیده

افزونه ای ندارید برای نمایش فلش در پست؟

پس مشکل از قالب شما هستش. چون همین کد به راحتی در چند تا سایت من جواب میده. فلش شما رابه راحتی گذاشتم . خودتون در سایدبار می تونید ببینید. در نوشته ها امتحان کردم. جواب میده.

برای فلش نیازی به افزونه نیست . با کد باید بهتون جواب بده. تو اینترنت جستجو کنید خیلی کدها هستش که دیگه باید یکی جواب بده در سایتتون. اما بازم میگم قالبتون یه جا مشکل داره که نون نمیده.

http://fa.ibforums.net/

ویرایش شده در توسط javad abbasi
2

به اشتراک گذاری این پست


لینک به پست

پس مشکل از قالب شما هستش. چون همین کد به راحتی در چند تا سایت من جواب میده. فلش شما رابه راحتی گذاشتم . خودتون در سایدبار می تونید ببینید. در نوشته ها امتحان کردم. جواب میده.

برای فلش نیازی به افزونه نیست . با کد باید بهتون جواب بده. تو اینترنت جستجو کنید خیلی کدها هستش که دیگه باید یکی جواب بده در سایتتون. اما بازم میگم قالبتون یه جا مشکل داره که نون نمیده.

http://fa.ibforums.net/

حق با شما بود قالب را عوض کردم فایل کار داد یه مسئله دیگه که من کدی که شما گفتید را وارد می کنم ولی زمانی که بروز رسانی را می زنم و بر می گردم کد ازش کم و زیاد شده به این جوری تغییر می کنه


<object width="256" height="200" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"><param name="src" value="http://ferasat.persiangig.com/neda/Files/Aazam.swf" /><embed width="256" height="200" type="application/x-shockwave-flash" src="http://ferasat.persiangig.com/neda/Files/Aazam.swf" /></object>

چرا؟

یعنی با یه کد دیگه ای ممکنه که فایل جواب بده ؟

0

به اشتراک گذاری این پست


لینک به پست

چی رو بروز میکنید کد عوض میشه؟

1

به اشتراک گذاری این پست


لینک به پست

حق با شما بود قالب را عوض کردم فایل کار داد یه مسئله دیگه که من کدی که شما گفتید را وارد می کنم ولی زمانی که بروز رسانی را می زنم و بر می گردم کد ازش کم و زیاد شده به این جوری تغییر می کنه


<object width="256" height="200" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"><param name="src" value="http://ferasat.persiangig.com/neda/Files/Aazam.swf" /><embed width="256" height="200" type="application/x-shockwave-flash" src="http://ferasat.persiangig.com/neda/Files/Aazam.swf" /></object>

چرا؟

یعنی با یه کد دیگه ای ممکنه که فایل جواب بده ؟

سیستم وردپرس یه جوری هست که وقتی بعضی از کدها را بهش میدی با توجه به نیاز خودش کدهای دیگه را روش اضافه می کنه تا قابل خوندن باشه. برای من خیلی پیش اومده. شاید اگر الان همون کد را تو قالبی که داشتین بذارین کار کنه.

2

به اشتراک گذاری این پست


لینک به پست

چی رو بروز میکنید کد عوض میشه؟

نه کلا اون کد هست ولی کد های دیگه ای هم بهش اضافه میشه

0

به اشتراک گذاری این پست


لینک به پست

من این مدل کد رو تست کردم مشکلی نداشته. شاید افزونه ایی چیزی هست که کد اضافه میکنه.

1

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

سلام

بالاخره با این کد کار داد


<"div class="ad-block aligncenter>
<a href="nedaj.ir"><embed width="256" height="200" src="http://ferasat.persiangig.com/neda/Files/Aazam.swf" alt="test ad"/><a>
</div>

ولی زمانی که اندازه عرض و لولش را بیشتر میکنم کا رنمیده

ویرایش شده در توسط runy
1

به اشتراک گذاری این پست


لینک به پست

کدتون مشکل داره اینو تست کنید :

<div class="ad-block aligncenter" style="width:300px;height:250px;">
<a href="nedaj.ir"><embed width="256" height="200" src="http://ferasat.persiangig.com/neda/Files/Aazam.swf" alt="test ad"/><a>
</div>

3

به اشتراک گذاری این پست


لینک به پست

کدتون مشکل داره اینو تست کنید :

<div class="ad-block aligncenter" style="width:300px;height:250px;">
<a href="nedaj.ir"><embed width="256" height="200" src="http://ferasat.persiangig.com/neda/Files/Aazam.swf" alt="test ad"/><a>
</div>

آره درست گفتید الان دیگه همه جا به راحتی کار میده ممنون

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری