4 پست در این موضوع قرار دارد

سلام دوستان

کسی راه حلی داره تا تقویم افزونه acf رو از میلادی به شمسی تبدیل کنه؟

افزونه های پارسی دیت، جلالی تست شد ولی کار نکردن.

0

به اشتراک گذاری این پست


لینک به پست
در 2 ساعت قبل، amirjahangiri گفته است :

سلام دوستان

کسی راه حلی داره تا تقویم افزونه acf رو از میلادی به شمسی تبدیل کنه؟

افزونه های پارسی دیت، جلالی تست شد ولی کار نکردن.

درود

اول از همه یه بکاپ بگیر بعدش

افزونهجلالی رو نصب کن :mellow:  بعد  

تمامی تگ های تاریخ رو به این تگ عوض کن the‪_‬time();‬

اگه نشد افزونه جلالی رو  تو هاست و خود پوشه این افزونه فایل wp‪-‬jalali‪.‬php  ویرایش کن بعدش این کدهارو پیدا کن

//add_filter("get_the_date","mps_the_jdate",10,4);
//add_filter("get_the_time","mps_the_jtime",10,4);

بعدش اون 2تا اسلش کدها رو پاک کن

درست شد نتیجه رو اعلام کن اگه نشد

این کد رو بگرد

if ($d == "") $d = get_option('time_format');

بعدش 2 تا کد شبیه به این پیدا میشه 2ومیش رو به این کد تغییر بده

if ($d == "") $d = get_option('date_format');

انشاالله که حل بشه

0

به اشتراک گذاری این پست


لینک به پست

چک کنید حتما سایت و هسته وردپرس افزونه ها بروز باشه

0

به اشتراک گذاری این پست


لینک به پست
در 14 ساعت قبل، Mohammad Bazli گفته است :

درود

اول از همه یه بکاپ بگیر بعدش

افزونهجلالی رو نصب کن :mellow:  بعد  

تمامی تگ های تاریخ رو به این تگ عوض کن the‪_‬time();‬

اگه نشد افزونه جلالی رو  تو هاست و خود پوشه این افزونه فایل wp‪-‬jalali‪.‬php  ویرایش کن بعدش این کدهارو پیدا کن


//add_filter("get_the_date","mps_the_jdate",10,4);
//add_filter("get_the_time","mps_the_jtime",10,4);

بعدش اون 2تا اسلش کدها رو پاک کن

درست شد نتیجه رو اعلام کن اگه نشد

این کد رو بگرد


if ($d == "") $d = get_option('time_format');

بعدش 2 تا کد شبیه به این پیدا میشه 2ومیش رو به این کد تغییر بده


if ($d == "") $d = get_option('date_format');

انشاالله که حل بشه

سلام روز بخیر 

هیچ کدوم از کدهایی که گفتی داخل wp-jalali.php نبود 

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط poutav
      سلام دوستان من سایت دانلود فیلم و سریال دارم و این قالبی که الان دارم ازش استفاده میکنم طراحش از آذرماه سال 97 تا الان دیگه جوابم رو نمیده و قالب لایسنس داره و الان لایسنسش منقضی شده و بعضی از بخش های سایت غیر فعال شده و گوگل خیلی بهم پیام میده که ایراد داره سایتت و برطرفش کن و سایتم خیلی بازدیدش اومده پایین. اگر کسی میتونه زمینه های دلخواه single post ها و باکس دانلود رو به قالب جدید انتقال بده لطفا قیمت رو پیشنهاد بدین.

      آدرس سایتم
    • توسط muhmdzarei
      سلام،
      در حال ساخت یک قالب آموزشی هستم. در صفحات دوره، لیست دوره ها رو قرار دادیم که کاربر ( بعد از شرایطی ) بر روی محتوا و درس مورد نظرش کلیک کنه و صفحه به قسمت ویدیوپلیر اسکرول بشه ولینک این درس با لینک قبلی جایگزین بشه ( با js ).
      مشکلمون در حقیقت اینه که اون  "بعد از شرایطی"  رو دقیقا نتونستیم اجرا کنیم. مشکل اینجاست که بعضی از درس های دوره رایگان هستند و همه کاربران ( چه خریدار و چه بازدیدکننده) میتوانند این ویدیو را ببینند. خریدار دوره نیز میتواند همه درس ها را ببیند. برای قرار دادن اطلاعات دروس در صفحه قالب ، از افزونه Advanced Custom Fields و قابلیت Nested Repeaters استفاده شده است. شرط هایی که قرار میدیم همش غلطه
      <ul class="course-accordion"> <?php if( have_rows('chapters') ): ?> <?php while( have_rows('chapters') ): the_row(); ?> <li class="accordion-option opened"> <div class="option-title"><?php the_sub_field('chapter'); ?></div> <div class="option-wrapper"> <ul class="option-items"> <?php if( have_rows('lessons') ): ?> <?php while( have_rows('lessons') ): the_row(); ?> <?php if( have_rows('lesson') ): ?> <?php while( have_rows('lesson') ): the_row(); ?> <li class="option-item"><a><?php if (the_sub_field('Lfree') == "True") { echo '1'; } else { echo '2'; } ?></a> <div class="pull-right"><span class="duration"></span><a href="#"><i class="zmdi zmdi-hc-2x"></i></a> </div> <a href="#"><?php echo the_sub_field('Lname'); ?></a></li> <?php endwhile; ?> <?php endif; ?> <?php endwhile; ?> <?php endif; ?> </ul> </div> </li> <?php endwhile; ?> <?php endif; ?> </ul> Lfree برای هر درس تعیین شده که برای این قرار گرفته که اگه این درس رایگان بود لینکش قابل دسترسی باشه. مشکل اینجاست وقتی مقدار Lfree برای هر درس رو چاپ می کنیم یه عبارت مشخصه. بعد شرط if میزاریم که اگر مساوی با اون عبارت بود... اما همیشه شرط غلط اجرا میشه. بنظرم باید مربوط به حلقه while و اینجور چیزا باشه
      ممنون از پاسختون
    • توسط alimelody
      درود به شما دوستان عزیز 
      یه سوال داشتم اگه ممکنه مثه همیشه که واقعا کمک کردین بازم راهنماییم کنید
      من توی سایتم یه سری پست میذارم که توی همشون باید لینک دانلود و یه سری جزئیات دیگه باشه
      حالا من میتونم همون دکمه‌ای که رنگی و با استایل همیشگی هستش رو در قسمت زمینه‌های دلخواه اضافه کنم
      مثلا من زمانی که میخوام دکمه رو اضافه کنم از قسمت ویرایشگر یه فلش هست کلیک میکنم و گزینه دانلود رو انتخاب میکنم و و بعد زنگ و عنوان و لینک دانلودرو مشخص میکنم و منتشر میکنم
      بعد اینکه این عملیاتو انجام میدم کد HTML بهش میگن دقیقا نمیدونم زبان کد چیه ولی یه کدی نمایش میده که مربوط به همون دکمه هستش و متن و لینکی که دادم میون این کد هستش 
      حالا من میتونم با استفاده از این کد توی زمینه‌های دلخواه استفاده کنم که هربار میخوام پست بذارم هی این عملیاتو انجام ندم
      اگه ممکنه فقط جوری بگین که متوجه بشم
      بخدا کلی مطلب خوندم و از اونجایی که علمشو ندارم هیچی حالیم نشد
      اگه شدنیه فقط بگین این کدرو به چه صورت قرار بدم همین 
      قربون مهربونیتون 
    • توسط Lightwoorld
      سلام صبح سوالی کردم یکی از دوستان این افزونه رو برای ساخت متاباکس پیشنهاد کرد
      من افزونه رو نصب کردم و تنظیمات افزونه رو انجام دادم یه بخش زیر ویرایش پست هام ایجاد شده. یعنی همون متاباکس ها که خودم ساختم
      من فیلد ها رو پر میکنم و ذخیره میکنم 
      اما تو سایت هیچ چیز نشون نمیده
      کلی سایت گشتم ولی هیچی پیدا نکردم
    • توسط -HADI-
      سلام خدمت دوستان،
      یک سری فیلد رو با افزونه ی Advanced Custom Fields ایجاد کردم، توی یکی از بخش ها که تعداد فیلد های زیاد تری داره وقتی پست رو منتشر میکنم نمایش نمیده بعضی قسمت هارو و هم توی بخش ارسال پست بعد از رفرش شدن صفحه ، خالی میشن بعضی فیلد ها!
      یه تصویر آپلود میکنم لطفا یه بررسی کنید در صورت امکان

       
      این تصویر بعد از انتشار پست و رفرش شدن ضفحه اس
      حتی بعضی مواقع اعداد هم حذف میشن