pirooz

مشکل در پیوند یکتا بر روی وردپرس چند سایته (شبکه)

8 پست در این موضوع قرار دارد

سلام

من وردپرس شبکه را بر روی iis 7.5 راه‌اندازی کردم. پس در نتیجه فایل .httaccess را نخواهم داشت.

مشکل من اینجاست که هیچ تنظیمی را به غیر از تنظیم پیوند یکتای پیشفرض (p=id?) نمی‌تونم قرار بدهم. یعنی اگر تنظیمی دیگه‌ای قرار بدهم، با خطای 404 مواجه می‌شم.

تنظیمات فایل web.config را طبق توصیه‌های متفرق به صورت زیر قرار دادم. دوستان اگر ممکن هست کمک کنند.

برای من خیلی مهم هست که بتونم از پیوند یکتایی غیر از پیش‌فرض استفاده کنم. چون افزونه multisite-global-search که برای جستجو در کل سایت‌ها هست، با هر تنظیمی غیر از تنظیم پیش‌فرض پیوند یکتا کار می‌کنه


<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<rewrite>
<rules>
<clear />
<rule name="Main Rule" enabled="false" stopProcessing="true">
<match url=".*" />
<conditions logicalGrouping="MatchAll">
<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
</conditions>
<action type="Rewrite" url="index.php/{R:0}" />
</rule>
<rule name="WordPress Rule 1" enabled="true" stopProcessing="true">
<match url="^index\.php$" ignoreCase="false" />
<conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
<action type="None" />
</rule>
<rule name="WordPress Rule 2" enabled="true" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?files/(.+)" ignoreCase="false" />
<conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
<action type="Rewrite" url="wp-includes/ms-files.php?file={R:2}" appendQueryString="false" />
</rule>
<rule name="WordPress Rule 3" enabled="true" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
<conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
<action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
</rule>
<rule name="WordPress Rule 4" enabled="true" stopProcessing="true">
<match url="^" ignoreCase="false" />
<conditions logicalGrouping="MatchAny" trackAllCaptures="false">
<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
</conditions>
<action type="None" />
</rule>
<rule name="WordPress Rule 5" enabled="true" stopProcessing="true">
<match url="^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*)" ignoreCase="false" />
<conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
<action type="Rewrite" url="{R:1}" />
</rule>
<rule name="WordPress Rule 6" enabled="true" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
<conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
<action type="Rewrite" url="{R:2}" />
</rule>
<rule name="WordPress Rule 7" enabled="true" stopProcessing="true">
<match url="." ignoreCase="false" />
<conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
<action type="Rewrite" url="index.php" />
</rule>
</rules>
</rewrite>
<httpErrors errorMode="DetailedLocalOnly" />
<defaultDocument>
<files>
<clear />
<add value="Default.htm" />
<add value="Default.asp" />
<add value="index.htm" />
<add value="index.html" />
<add value="iisstart.htm" />
<add value="default.aspx" />
<add value="index.php" />
</files>
</defaultDocument>
</system.webServer>
</configuration>



0

به اشتراک گذاری این پست


لینک به پست

سلام

وردپرس شبکه با ویندوز سرور خیلی سازگار نیست. حتی همینکه روی ویندوز تونستید نصب کنید خیلی خوبه!

شما میتونید محتویات فایل htaccess رو در بخش rewrite ویندوز تبدیل به کانفیگ ویندوزی کنید.(روی ویندوز سرور 2008 تست شده)

0

به اشتراک گذاری این پست


لینک به پست

یه خورده کانفیگ ری رایت پیچیده هست. مشخصا برای مشکل پیوند یکتا کانفیگی سراغ دارید؟

توی مستندات وردپرس کانفیگ برای پیوند یکتا روی ویندوز پیدا کردم اما توی وردپرس شبکه جواب نمیده.

0

به اشتراک گذاری این پست


لینک به پست

این رو تست کنید. البته مطمئن نیستم:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<rewrite>
<rules>
<rule name="WordPress Rule 1" stopProcessing="true">
<match url="^index\.php$" ignoreCase="false" />
<action type="None" />
</rule>
<rule name="WordPress Rule 2" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?files/(.+)" ignoreCase="false" />
<action type="Rewrite" url="wp-includes/ms-files.php?file={R:2}" appendQueryString="false" />
</rule>
<rule name="WordPress Rule 3" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
<action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
</rule>
<rule name="WordPress Rule 4" stopProcessing="true">
<match url="^" ignoreCase="false" />
<conditions logicalGrouping="MatchAny">
<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
</conditions>
<action type="None" />
</rule>
<rule name="WordPress Rule 5" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
<action type="Rewrite" url="{R:2}" />
</rule>
<rule name="WordPress Rule 6" stopProcessing="true">
<match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
<action type="Rewrite" url="{R:2}" />
</rule>
<rule name="WordPress Rule 7" stopProcessing="true">
<match url="." ignoreCase="false" />
<action type="Rewrite" url="index.php" />
</rule>
</rules>
</rewrite>
<directoryBrowse enabled="false" />
</system.webServer>
</configuration>

1

به اشتراک گذاری این پست


لینک به پست

خطای 404 :(

0

به اشتراک گذاری این پست


لینک به پست

این رو برای کاری تهیه کرده بودم اما کلا در اینمورد کمی کارتون سخت هست چون منبع مناسبی وجود نداره

0

به اشتراک گذاری این پست


لینک به پست

سلام

من منابع فارسي و انگليسي را زير و رو كردم. همشون يك سري پيشنهاد مي‌دهند و تمام.

هيچ كدام كار من رو راه ننداخته.

خيلي كارم گيره اين مطلب هست. در واقع سرچ توي كل سايت‌هاي تحت پوشش شبكه احتياج به پيوند يكتاي به اصطلاح زيبا داره كه اين هم براي من مقدور نيست.

0

به اشتراک گذاری این پست


لینک به پست

بخاطر همین نوع مشکلات کلا سرور ویندوزی رو کنار گزاشتم. حتی خود منبع رسمی وردپرس هم دراین مورد چیزی منتشر نکرده.

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط sepehrsiasat
      سلام
      سایتی که دارم چن بخش داره که برای اینکه قالب های متفاوت و اینا نیاز داره مجبور شدم با ساخت ساب دامین این بخش ها رو جدا کنم ( بخش آموزش/دانلود/آزمون/...)
      حالا میخوام همه اینا بهم وصل باشه و کسی که یک بار لوگین میکنه توی یدونه از اینا دیگه نخواد توی بقیه هم لوگین کنه:
      دو تا راه بهم گفتن:
      1- برای هر ساب دامین یه وردپرس جدا بزنم و بعد همه رو به یه دیتابیس وصل کنم و اسم جداول رو باید یه کم عوض کنم که خیلی بلد نیستم
      2- استفاده از وردپرس شبکه ( که فقز در حالت ساب دامین به من اجازه میداد)
      حالا من وردپرس شبکه روی سایت اصلی ام (doctorabad.com) ایجاد کردم و از قبل توی cpanel ساب دامین ها رو هم تعریف کردم پیشخوان سایت اصلی هم مشکلی نداره ولی وقتی میخوام وارد بخش پیشخوان ساب دامین هام مینویسه:
      Not Found
      The requested URL /wp-admin/ was not found on this server.
      Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
       
      خب راست هم میگه وقتی میرم توی cpanel و پوشه مربوط به هر ساب دامین رو می بینم فقط یه فولدر cgi-bin توش هست که توی این فولدر هم خالیه و فولدر wp-admin اصلا نداره 
      یه جاهایی خوندم که انگار به ازای هر ساب دامین توی وردپرس شبکه باید خودش یه فایل .htaccess هم بسازه ولی خب برای من نساخته
       
      یه فیلم هم در زیر ضمیمه کردم ببینید
      واقعا ممنون میشم کمکم کنید
      2017-07-25_23-08-17.mp4
    • توسط رضا علیزاده
      با سلام و عرض ادب خدمت اساتید
      چند وقت پیش سایتی راه اندازی کردم و ساختار پیوندیکتای اون رو به حالت زیر گذاشتم؛
      /%year%/%monthnum%/%postname%.html توی این مدت ایندکس ها و سئو نسبتاً خوبی هم گرفته, اما تا حدودی لازم دیدم که پیوندیکتا به شکل زیر تغییر کنه؛
      /%category%/%postname%/  
      حالا سوال اینجاست؛
      - آیا راهی هست که با تغییر این پیوندیکتا مطالب و ایندکس های سایت دچار خطای 404 نشه ؟
       
      ممنون میشم راهنمایی کنید
    • توسط jevad
      سلام به همه دوستان.
      در وردپرس شبکه هنگام عضویت یک کاربر ، چکار کنم ک کاربر جدید در حین ثبت نام یکی از قالبهایی ک قبلا در شبکه فعال شدن و برای خودش انتخاب کنه( قبل از ورود ب پیشخوان) ک وقتی ک ثبت نامش تموم شد و وارد پیشخوان شد همون قالبیو ک انتخاب کرده براش فعال شده باشه.
      خلاصه بگم مثل سایت see5.ir
    • توسط AbbasZandPour
      سلام.
      من وردپرس شبکه رو نصب کردم و مراحل رو به درستی انجام دادم ولی یه مشکلی دارم 
      داخل ویلد کارت وردپرس رو نصب کردم و وقتی که بلاگ جدیدی ساخته میشه تمامی ادرس های قالب به abbas.nightblog.in میره
      حتی لاگین خود وردپرس
       
    • توسط frzne
      سلام
      من چند وقت پیش برای چند زبانه کردن سایت، از وردپرس شبکه استفاده کردم و بدون مشکل نمایش داده می شد. اما بعد از مدتی بنا به دلایلی مجبور به تغییر دامنه و هاست شدیم.
      فول بک آپ تهیه کردم و سایت رو به هاست جدید انتقال دادم. به خاطر اینکه دامنه هم تغییر کرده بود، نام دامنه رو در پایگاه داده در قسمت wp_options تغییر دادم.
      حالا سایت اصلی بدون مشکل نمایش داده میشه. اما سایت های دیگه که با وردپرس شبکه پیاده سازی شده بودن نمایش داده نمیشه. صفحه ی 404 میاد. البته نه صفحه ی 404 خودِ سایت!
      The resource requested could not be found on this server!
      اسکرین شات از صفحه رو پیوست کردم.
      جالب اینجاست که صفحات داخلی زیر سایت ها باز میشن. فقط صفحه اصلی شون باز نمیشه.
      یعنی mysite.ir/en/about باز میشه اما mysite.ir/en باز نمیشه!
      لطفا راهنمایی کنید. خیلی مهمه!!