reza_yki

عدم نمایش تصاویر در صفحه اول

5 پست در این موضوع قرار دارد

سلام به همه اعضا

من یه پوسته دارم این یه مشکل داره اونم اینه که وقتی نوشته ای که جدید می زنم ویه عکس میزارم تو صفحه اول نمایش نمی ده ولی وقتی ادامه مطلب رو میزنم نشونش میده مشکلش از کجا میتونه باشه اگه لازم بود کدشم میزارم

به اشتراک گذاری این پست


لینک به پست

احتمالا کد شما به جای مطلب خلاصشو میزاره. شما تو index.php ببین اگه the_excerpt داری با the_contentعوضش کن یا کد رو بزار اینجا تا بررسی بشه.

به اشتراک گذاری این پست


لینک به پست

نبودش والا من دارم یه پوسته رو ترجمه میکنم فقط این قسمتش مشکل داره

فک کنم مربوط به این قسمت باشه:

		    <?php
if(has_post_thumbnail()) {
?>
<div class="featured-image-container"><a href="<?php the_permalink(); ?>"><?php the_post_thumbnail('medium'); ?></a></div><?php
}
?>

به اشتراک گذاری این پست


لینک به پست

این قسمت مربوط به تصویر شاخص میشه، برای نمایش این قسمت باید هنگام ارسال پست تصویر شاخص را هنگام انتشار مشخص کنید.

اگه مایلی می تونی سورس ایندکس را کامل بزاری تا با دید بهتری بهتون کمک بشه.

به اشتراک گذاری این پست


لینک به پست

ببینید می تونید مشکلشو پیدا کنید:

<?php global $theme; get_header(); ?>
<div id="main">

<?php $theme->hook('main_before'); ?>
<div id="content">

<?php $theme->hook('content_before'); ?>

<?php
$is_post_wrap = 0;
if (have_posts()) : while (have_posts()) : the_post();
/**
* The default post formatting from the post.php template file will be used.
* If you want to customize the post formatting for your homepage:
*
* - Create a new file: post-homepage.php
* - Copy/Paste the content of post.php to post-homepage.php
* - Edit and customize the post-homepage.php file for your needs.
*
* Learn more about the get_template_part() function: http://codex.wordpress.org/Function_Reference/get_template_part
*/
$is_post_wrap++;
if($is_post_wrap == '1') {
?><div class="post-wrap clearfix"><?php
}
get_template_part('post', 'homepage');

if($is_post_wrap == '2') {
$is_post_wrap = 0;
?></div><?php
}

endwhile;

else :
get_template_part('post', 'noresults');
endif;

if($is_post_wrap == '1') {
?></div><?php
}

get_template_part('navigation');
?>

<?php $theme->hook('content_after'); ?>

</div><!-- #content -->

<?php get_sidebars(); ?>

<?php $theme->hook('main_after'); ?>

</div><!-- #main -->

<?php get_footer(); ?>

خیلی ممنون رفع شد از همون قسمت تصاویر شاخص بود :D

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط aminq10
      سلام و خسته نباشید
      من یک پوسته طراحی کردم
      روی سایت فعال کردم اما بعد از هر اکشنی صفحه سفید میاد در قسمت مدیریت سایت
      مثلا : توی ویرایش پوسته وقتی پوسته را ویرایش میکنیم و گزینه ویرایش را میزنم بعدش صفحه سفید میاد ولی پوسته هم ویرایش میشه
      یا مثلا وقتی یه افزونه را ادیت میکنم
      یا مثلا وقتی میخوام یه افزونه را سرچ و نصب کنم هیچ اتفاقی نمیافته
      یا مثلا وقتی درخواست رمز جدید میدم روی لینکی که به ایمیل اومده کلیک میکنم صفحه سفید میاد
      وقتی هم یک پوسته دیگه فعال میکنم این مشکل را ندارم
    • توسط alidoulatyocan
      سلام دوستان.من یه پوسته شبکه اجتماعی میخوام.مواردی رو دیدم.ولی بدردم نخورد.من یه پوسته میخوام شبیه جامعه دوستیابی که کاربرها اشتراک ویژه بگیرن.اگر کسی میشناسه معرفی کنه سپاس.
    • توسط taha1414
      باسلام خداقوت
      بنده سایتی با قالب صحیفه - از یکی از سایت های دانلود رایگان-  راه اندازی کردم. ووکامرس هم نصب کردم
      حالا چند مشکل دارم که واقعا عاصی شدم و هر کار کردم درست نشد و حتی سایتی که قالب رو گرفتم هم جواب درست حسابی ندادن... / ضمنا از چند سایت دیگه هم قالب رو گرفتم ولی باز نشد.
      1. فونت های فارسی موجود در قالب کار نمی کنند؟
      2.در نمایش محصولات ووکامرس در صفحه اول نمایش درست و ارایشی ندارد؟
      3.تصاویر هم گاهی لود نمی شود؟
       
      سایت مورد نظر: tolidemihan.ir
      باتشکر از پاسخ هایتان...
       
       
    • توسط sky
      سلام من یک پوسته جدید برای سایت نصب کردم بعد از نصب پوسته سایت مدام در حالت لود قرارداره و کامل باز نمیشه
      ولی قالب قبلی این مشکل رو نداشت لطفا راهنمایی کنید
    • توسط zodiac
      سلام و خسته نباشید خدمت تمامی عزیزان
      من حدودا یه ماهی میشه که به جمع کاربران ورد پرس وارد شدم ولی مشکل جدی در پست گذاشتن به زبان فارسی دارم و وقتی که پست میزارم نام پست، متن پست، نام دسته به علامت سوال«؟» تبدیل میشه
      لطفا راهنمایی کنین که چجوری مشکل رو حل کنم
      زبان خوده وردپرس فارسی ـیه و مشکلی نداره
      البته در سایت به صورت تکه تکه نوشته شده است
      خیلی ممنون
      آدرس سایت: 
      ic.xzn.ir/zodiac