shp1367

مشکل لود شدید vps با پیوند یکتا

7 پست در این موضوع قرار دارد

سلام،

خسته نباشید دوستان،

سایت من مدتی بود به خاطر اینکه سی پی یو و رم مصرفش غیر عادی شده بود سنگین لود میشد دیگه کار به جایی رسید که سایت باز نمیشد و مجبور شدم تست کنم ببینیم اشکال از چیه.

برای همین یکی یکی رفتم جلو و یه وردپرس خالی بدون دیتابیس بالا آوردم روی سایت و همه چی عالی بود بعد قالب سایت رو روش گذاشتم و باز همه چی عالی بود ، بعد افزونه هایی که استفاده میکردم رو گذاشتم و فعال کردم و همه چی نرمال بود تا اینکه دیتابیس رو ایمپورت کردم و لود سایت شدیدا بالا رفت.

تا اینجا معلوم شد از دیتابیسه!

بعد یکی یکی تیبل های دیتابیس رو جایگزین کردم با دیتابیس دیفالت ، از تیبل پست گرفته تا تگ و کامنت و افزونه ها ...

یکی یکی تیبل ها رو وارد کردم

اول فکر کردم از تگ ها هستش که فارسی هستن اما در نهایت به این جا رسیدم که مشکل فقط پیوند یکتا هست!

یعنی وقتی نوع پیوند رو روی پیوند دیفالت وردپرس میذارم همه چی عالیه و لود سایت عالیه ، اما به محض گذاشتن روی پیوند یکتای ماه و نام و اسم نوشته همه چی

داغون میشه و لود سی پی یو و رم vps میره تا آسمون و سایت و vps کلا هنگ میشه دیگه.

میخواستم ببینم چیکار باید بکنم؟ من سایتهای همکار زیادی رو دیدم که با پیوند یکنای فارسی هستن و بازدیدشون مثل من هست اما ازشون که پرسیدم

مشکل لود ندارن .

من چند جا خوندم که اشکال از Apache mod_rewrite هست و باید کد زیر رو تو .htaccess بذارم تا مشکل حل شه اما نشد باز.

# BEGIN WordPress

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteBase /

RewriteRule ^index\.php$ - [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . /index.php [L]

</IfModule>

# END WordPress

به نظرتون باید من الان چیکار باید بکنم؟

خیلی واجبه چون سایت چند روزه سره این مشکل مرتب داره دان میشه.

ممنون

1

به اشتراک گذاری این پست


لینک به پست

این کدی که گذاشتید برای استفاده از پیوند یکتا خودش در فایل htaccess ایجاد میشه .

Apache mod_rewrite مربوط ب تنظیمات سرور باید باشه . شما باید این قابلیت رو فعال کنید روی سرور که به احتمال زیاد فعال نیست . این میتونه دلیل لود بالای سایت شما باشه .

با مدیر سرور صحبت کنید فکر کنم در این مورد راهنمایی های لازم رو به شما بکنه . این مورد رو هم ببینید : (منبع : انجمن وب هاستینگ تالک)

لبته برای فعال کردن باید ماژول Mod_rewrite توسط آپاچی به کار گرفته بشه

برای این کار فایل http.conf رو با یک ویرایشگر باز کنید

yum isntall nano

nano /etc/httpd/conf/httpd.conf

ctrl+w ( سرچ )

به دنبال این عبارت بگردید : LoadModule rewrite_module modules/mod_rewrite.so

مطمئن بشید که قبل اون علامت کامند (#) قرار نداشته باشه ( اگه بود ، # رو پاک کنید )

بازهم ctrl + w

به دنبال AllowOverride None بگردید و به AllowOverride All تغییر بدید

وب سرور رو با دستور

service httpd restart

راه اندازی مجدد کنید .

4

به اشتراک گذاری این پست


لینک به پست

ممنون،

یعنی به صرف این کد ، این مد تو آپاچی فعال نمیشه؟ درسته؟

و باید از خود آپاچی هم کانفیگ بشه و ران باشه؟

0

به اشتراک گذاری این پست


لینک به پست

بله . دقیقاً

0

به اشتراک گذاری این پست


لینک به پست

سلام،

من خودم یه برنامه WINSCP رو گرفتم تا بتونم به vps دسترسی داشته باشم چون نتونستم با putty کار کنم!

الان این فایل http.conf رو گرفتم از اینجا /usr/local/apache/conf اما هرچی سرچ زدم کلا این دستور توش نبود، چجوری و کجا باید اضافش کنم؟

آیا این مسیری که فایل رو ازش گرفتم درسته؟

ممنون

0

به اشتراک گذاری این پست


لینک به پست

من متاسفانه آشنایی ندارم با تنظیمات سرور .

از مدیر سرور بخواید این کار رو براتون انجام بده و یا در موردش جستجو کنید .

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط iranibonsai
      درود، سایتی رو با وردپرس بالا آوردیم
      اما اکنون در صفحات داخلی سایت کد خطایی رو در بخش بالای مرورگر نشون میده که نتونستیم رفعش کنیم
      Warning: count(): Parameter must be an array or an object that implements Countable in /home3/zahrefzo/public_html/wp-includes/post-template.php on line 284
      این خطا قبلا وجود نداشت، نفهمیدم به چه علتی بوجود آمده و تو اینترنت هم چیز خاصی راجعبه رفعش پیدا نکردم، ممنون میشم اعلام نظر بفرمایید
      آدرس سایت :
      http://minelbeautysalon.com//
    • توسط majid_one

      من به  تازگی سایتی راه اندازی کردم و از این که ابزار ها و افزونه هایی که در اینترنت به فروش میرسن استایلشون با قالب من جور در نمیان و یا نمیتونم سفارشیشون کنم برای خودم

      میخواستم بپرسم این ابزار ها با چه کدی نوشته شدن و آیا میشه همه جوره توشون دست برد و برای خودت سفارشیشون کرد و استایلشون رو شبیه استایل قالب وبسایت خودت کنی؟
    • توسط ashkan91
      با سلام و خسته نباشید
      دوستان کسی میدونه چطور میشه فیلد ایمیل رو از تو فرم تسویه حساب ووکامرس غیرضروری کرد؟ (بدون استفاده از افزونه) یکی از دوستان این لینک رو فرستادن اما نمیدونم کدام تکه کد از این صفحه را میبایست درون کدهای سایت قرار بدم که مشکل حل بشه؟
      https://docs.woocommerce.com/document/tutorial-customising-checkout-fields-using-actions-and-filters/#example-make-phone-number-not-required
    • توسط amirmehdi950
      سلام روزتون بخیر
      من میخوام از افزونه ultimate member private message استفاده کنم اما یه چیزی کم داره.
      میخوام دکمه پیوست هم داشته باشه.
      (این افزونه همونطوری که از اسمش پیداست برای ارسال پیام خصوصی بین کاربرا ساخته شده، افزونه private message به تنهایی کار نمیکنه و باید ultimate member هم نصب باشه که افزونه بسیار خوبیه.)
      حالا من سوالی که دارم اینه که چطوری میشه این دکمه رو هم به قسمت چت اضافه کرد و از کجا باید کدهاشو ویرایش کرد
      این هم تصویر افزونه ( محل جایگذاریش میخوام کنار بخش emoji باشه)
       

      ممنونم
    • توسط mohamad7072
      سلام دوستان خسته نباشید 
      من میخوام ظاهر سایتم رو عوض کنم مثلا صفحه اول سایتم رو تغییر دادم اما این تغییرات اعمال نمیشه یا مثلا یه افزونه رو کامل پاک کردم ولی هنوز اثراتش هست 
      همه این مشکلات وقتی هست که به عنوان کاربر مهمان وارد سایت میشم ولی وقتی لاگین میکنم همه چی درست میشه...
      مشکل از چیه کسی میتونه کمکم کنه؟؟