18 پست در این موضوع قرار دارد

ارسال شده در (ویرایش شده)

سلام به همگی

اساتید محترم من حدود 10 روزی میشه که یه سایت راه اندازی کردم و هاستم رو هم از اینجا گرفتم ( LV1 ) و اینطور که خودشون گفتن هاست vip از هاست معمولی خیلی بهتره و کمتر با محدودیت منابع مواجه می شیم ولی متاسفانه همینطور که در تصویر

post-639-0-44667700-1361721945_thumb.jpg

مشاهده می کنید مصرف سی پی یو خیلی توی این 7 روز بالا بوده با اینکه من بازدید کننده ای به اون صورت نداشتم ( نهایت روزی 10 نفر ) و فقط از افزونه های 404 Redirection و Akismet و All in One SEO Pack و contactform7 و Google XML Sitemaps و wp-jalali و WP-Optimize استفاده می کنم .

در ضمن در پیوندهای یکتا هم از حروف فارسی استفاده نکردم . قالب هم که قالب خود وردپرسه ( دوهزار و دوازده ) .

error log سی پنل هم :


2013-02-24 19:14:22.269 [INFO] [HTAccess] Updating configuration from [/home/smscom1/public_html/.htaccess]
2013-02-24 17:28:46.608 [INFO] [HTAccess] Updating configuration from [/home/smscom1/public_html/.htaccess]

محتویات فایل htaccess هم :


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

توی این یه هفته تقریبا خیلی جستجو کردم و مطالب زیادی رو هم خوندم ولی تاثیری نداشت و یکی 2 بار هم در حین ارسال مطلب با ارور 500 مواجه شدم .

بیشتر نگران این هستم که اگه بازدید کننده ها زیاد شن باید چیکار کنم !

ممنون می شم راهنمایی کنید .

ویرایش شده در توسط davo0d
0

به اشتراک گذاری این پست


لینک به پست

error log های جدید سی پنل :


2013-02-24 23:12:56.849 [INFO] [HTAccess] Updating configuration from [/home/smscom1/public_html/.htaccess]
2013-02-24 22:30:25.695 [INFO] [HTAccess] Updating configuration from [/home/smscom1/public_html/.htaccess]
2013-02-24 22:27:09.727 [INFO] [2.176.233.173:53247-0#APVH_sms19.com] File not found [/home/smscom1/public_html/500.shtml]

احساس می کنم وقتی یه مطلب ارسال می کنم بیش از اندازه طول می کشه تا ثبت بشه ...

0

به اشتراک گذاری این پست


لینک به پست

فکر میکنم mod_rewrite برای سرورتون کانفیگ نشده .

شما فایل htaccess رو رینیم کنید و پست هاتون رو با همون لینک دهی پیشفرض ست کنید به احتمال زیاد مشکلتون حل میشه .

منم تجربه استفاده از برتینا رو داشنم اما اصلاً راضی نبودم .

5

به اشتراک گذاری این پست


لینک به پست

همه افزونه ها را غیر فعال کنید و تست کنید و ارسال مطلب کنید بعد اگر خوب بود شروع کنید دانه دانه فعال کنید و تست کنید ببینید مشکل از کدام می تونه باشه.

3

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

فکر میکنم mod_rewrite برای سرورتون کانفیگ نشده .

شما فایل htaccess رو رینیم کنید و پست هاتون رو با همون لینک دهی پیشفرض ست کنید به احتمال زیاد مشکلتون حل میشه .

منم تجربه استفاده از برتینا رو داشنم اما اصلاً راضی نبودم .

ممنون

آخه نمی خوام از نامک پیشفرض استفاده کنم .

من به غیر از برتینا از هاست ایران هم استفاده کردم که اصلا از پشتیبانیشون راضی نبودم چون فقط تو ساعت اداری پاسخ تیکت ها رو می دادن ! بعد از ساعت اداری و روزهای تعطیل هم کلا کرکره رو می کشیدن پایین و می رفتن ولی برتینا پشتیبانیش خوبه .

اگه به نظرتون با نقل مکان مشکل حل میشه شما چه هاستی رو پیشنهاد می کنید ؟

همه افزونه ها را غیر فعال کنید و تست کنید و ارسال مطلب کنید بعد اگر خوب بود شروع کنید دانه دانه فعال کنید و تست کنید ببینید مشکل از کدام می تونه باشه.

مطمئن هستم از افزونه ها نیست چون قبلا رو یه هاست دیگه همین افزونه ها رو بهمراه چندین ! افزونه دیگه بکار بردم ولی مشکلی نداشتم ...

ویرایش شده در توسط davo0d
0

به اشتراک گذاری این پست


لینک به پست

مطمئن هستم از افزونه ها نیست چون قبلا رو یه هاست دیگه همین افزونه ها رو بهمراه چندین ! افزونه دیگه بکار بردم ولی مشکلی نداشتم ...

اینطور نگید. درسته افزونه های شما شاید مشکلی نداره اما ممکنه با هاست جدید سازگاری نداشته باشه و اینطوری افزونه ناسازگار رو پیدا می کنید و بعر می توانید یا با برتینا مطرح کنید تا مشکل را بر طرف کنند یا افزونه مهمی نیست و خاموشش کنید یا سایت را به هاست دیگری انتقال دهید.

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

فکر میکنم mod_rewrite برای سرورتون کانفیگ نشده .

من این موضوع رو با پشتیبانی در میان گذاشتم و این پاسخ را دادند :

کاربر گرامی mod_rewrite بر روی تمامی سرور های لینوکس فعال می باشد و مشکلی ندارد . می توانید با یک اچ تی اکسس ساده تست نمایید .

ویرایش شده در توسط davo0d
0

به اشتراک گذاری این پست


لینک به پست

دوستان من فعلا ساختار پیوند یکتا رو به


/%post_id%/%postname%/

تغییر دادم ببینم مشکل حل میشه یا نه ...

0

به اشتراک گذاری این پست


لینک به پست

دوستان من فعلا ساختار پیوند یکتا رو به


/%post_id%/%postname%/

تغییر دادم ببینم مشکل حل میشه یا نه ...

با ساختار فوق مصرف cpu تا 50 % کاهش یافت اما با توجه به تعداد بازدید و ... هنوز هم به نظرم زیاد هست و فعلا مجبورا از پیوند یکتا پیشفرض استفاده می کنم اگه تا فردا مشکل حل شد همینجا اعلام می کنم تا دوستانی که با مشکل مشابه مواجه شدند استفاده کنند .

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

من از پیوند یکتا پیشفرض استفاده کردم و مصرف cpu در 24 ساعت گذشته post-639-0-59168500-1361899983_thumb.jpg به نظر شما این طبیعیه ؟


2013-02-26 20:43:32.092 [INFO] [HTAccess] Updating configuration from [/home/smscom1/public_html/.htaccess]
2013-02-26 20:38:47.414 [INFO] [66.249.73.78:52564-0#APVH_sms19.com] File not found [/home/smscom1/public_html/404.shtml]
2013-02-26 20:38:47.414 [INFO] [66.249.73.78:52564-0#APVH_sms19.com] File not found [/home/smscom1/public_html/assets/application-171f786f6ad27f65f597a515f52ac06f.css]
2013-02-26 20:38:36.541 [INFO] [66.249.73.78:47629-0#APVH_sms19.com] File not found [/home/smscom1/public_html/404.shtml]
2013-02-26 20:38:36.541 [INFO] [66.249.73.78:47629-0#APVH_sms19.com] File not found [/home/smscom1/public_html/assets/polyfills-10c430c13b422cc159d2a0dc768e50ef.js]
2013-02-26 20:38:25.656 [INFO] [66.249.73.78:48225-0#APVH_sms19.com] File not found [/home/smscom1/public_html/404.shtml]
2013-02-26 20:38:25.656 [INFO] [66.249.73.78:48225-0#APVH_sms19.com] File not found [/home/smscom1/public_html/assets/welcome-5ec1f6328ce3ab9ded6ebbe7b1909b72.js]
2013-02-26 20:38:12.523 [INFO] [66.249.73.78:59653-0#APVH_sms19.com] File not found [/home/smscom1/public_html/404.shtml]
2013-02-26 20:38:12.523 [INFO] [66.249.73.78:59653-0#APVH_sms19.com] File not found [/home/smscom1/public_html/144/antigirl1/]
2013-02-26 20:11:02.997 [INFO] [HTAccess] Updating configuration from [/home/smscom1/public_html/.htaccess]
2013-02-26 19:36:36.525 [INFO] [HTAccess] Updating configuration from [/home/smscom1/public_html/.htaccess]

ویرایش شده در توسط davo0d
0

به اشتراک گذاری این پست


لینک به پست

همونطور که عرض کردم به نظر میرسه کانفیگ سرور شما با ساختار پیوند یکتا مشکل داره و mod_rewrite حداقل برای سرویس شما بخوبی عمل نمیکنه .

الان با توجه به این عکس مصرف cpu بهینه تر شده و فقط پیک های نا منظمی داره که باید بررسی بشه بابت چی اینطوری میشه . ارور های موجودی هم که نوشتید مربوط به 404 هایی میشه به کاربرانی که روی لینک های قبلی شما (با ساختار قبلی پیوند یکتا) کلیک کردن و با خطای not found مواجه میشن .

2

به اشتراک گذاری این پست


لینک به پست

می دونم اینجا جاش نیست ولی میشه ازتون خواهش کنم یه هاست خوب و قابل اعتماد از طریق پیام خصوصی بهم معرفی کنید که با mod_rewrite مشکلی نداشته باشه و کلا با وردپرس مشکل نداشته باشه ...

نمی خوام یکسال زحمت بکشم و تا بازدید کننده پیدا کردم از همه چی خسته شم !

ممنون می شم .

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

شما از این هم استفاده کنید خوبه جتپک توسط WordPress.comسایت شما رو به سرور وردپرس متصل میکنه به بعصضی از افزونه ها نیاز نداری

برای کم کردن cpu در تصاویر از Image Optimizerو

و از WP-Optimize پاکسازی دیتابیس و حذف رونوشت ها

و از این برای فشرده سازی WP HTTP Compression

و WP Super Cache هم که نصب کردین

درضمن به احتمال زیاد با توجه به میزان کم بودن افزونه های نصب شده

فکر کنم قالب شما قالب ریپ شده است معمولا قالب های غیر رایگان باگ دارن و این یکی از مشکلات هست

ویرایش شده در توسط mortezafox
3

به اشتراک گذاری این پست


لینک به پست

سلام

منم روی نت افراز هستم روزی چندتا تذکر میفرستن که سایتت مصرف سی پی یو ش زیاده

لاگ هایی هم که میفرستن همه مربوط به قسمت نظرات هست چون مطالب سایت نظر زیاد داره !(یعنی یه پست میفرستم فورا کاربران میان نظر میفرستن اول دوم میکنن !!! ) چطوری مصرف رو کم کنم WP Super Cache هم نصب کردم تاثیری نداشت

الان کلا بخش نظرات رو بستن ! راه حل بدید لطفا :(

0

به اشتراک گذاری این پست


لینک به پست

میتونید برای بخش نظرات از سرویس هایی مثل disqus استفاده کنید

2

به اشتراک گذاری این پست


لینک به پست

میتونید برای بخش نظرات از سرویس هایی مثل disqus استفاده کنید

غیر از disqus چیزای دیگه ای هستن ؟

میخوساتم شکلک هم داشته باشن ! قسمت نظراتم شکلک داشت ولی با این disqus مثل اینکه نمیشه گذاشت

0

به اشتراک گذاری این پست


لینک به پست

اگر قسمت نظرات رو آجاکس کنم بازم همون فشار رو میاره ؟

0

به اشتراک گذاری این پست


لینک به پست

ایجاکس و غیر اون فرقی نداره

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط Hamedgh
      سلام 
      من میخوام بخش دیگری رو به وبسایت الحاق کنم 
      از بین ساب فولدر و ساب دامین بنابر همگونی سایت اصلی با سایت روی ساب فولدر در رنکینگ ؛ موتورهای جستجو و سئو نسبت به ساب دامین میخوام وردپرس دومم رو روی ساب فولدر نصب کنم 
      الان یک ساب دامین ساختم و در document root  مسیر public_html/fanous براش نوشتم 
      الان وردپرس رو در پوشه fanous در مسیر public_html قرار بدم و نصب کنم؟ برای سایت اصلی مشکلی پیش نمیاد ؟ 
    • توسط shahrzad
      سلام 
      برای من مشکلی پیش آمده که اگر کمکم کنید حلش کنم ممنون میشوم.
       بعد از بروز رسانی قالب وبسایتم، دیگر کامپوننت های جاوااسکریپتی اجرا نمیشوند و حتی در سورس کد نمی آیند. مثلا پلاگین ulike دیگر نمیتوان لایک کرد. 
      آدرس سایت shahinkalantari.com 
      پ.ن: با جستجو در پرسشهای قبلی دیدم که کسی مشکلی مانند مسئله من داشته است. راه حلی که به ایشان ارائه شده بود را امتحان کردم اما جواب نگرفتم. 
    • توسط Pluto65
      سلام
      وردپرس 4.8.1 دارم و افزونه پارسی دیت را نصب کرده ام.این افزونه، ابزارکی به نام "بایگانی تاریخ خورشیدی" دارد که تاریخ را به شمسی تبدیل می کند اما فونت نمایش اعداد در آن با فونت اصلی سایت منطبق و هماهنگ نیست.
      برای سایت از فونت "یکان" استفاده کرده ام و در تمام سایت این فونت اعمال شده اما در این ابزارک اعمال نمی شود.
      لازم به ذکر است با افزونه جلالی هم تست کردم و همین مشکل در آن جا هم وجود داشت.
       
      برای حل مشکل، راهنمایی بفرمایید .

    • توسط jistili1
      سلام دوستان.من میخوام افزونه ajax search lite رو که برای جستجوی پیشرفته در سایت هستش ، یکمی از لحاظ ظاهری ویرایش کنم.مثلا فونت متنی که برای جستجو کاربر وارد میکنه رو بزرگتر کنم یا طول کادر وارد کردن متن جستجو رو بزرگ و کوچیک کنم.ممنون میشم راهنمائیم کنید چطوری این کار رو بکنم.
    • توسط younram
      سلام /
      من یک افزونه میخوام که وقتی چند ویرایشگر رو تعریف کردم . هیچ کدام از ویرایگران مطالب هم دیگر رو نبینند .
      و هر کاربری که وارد CMS وردپرس بشه فقط مطالبی رو بتونه ببینه که خودش قرار داده و دیگر مطالب نمایش داده نشه .
      ممنون میشم راهنمایی لازم رو بهم بدید .
      با تشکر