farnaz

زمینه دلخواه پیشرفته

11 پست در این موضوع قرار دارد

ممنون بابت این آموزش مفید.

الان یک مشکل دارم و اون اینکه در سایت متن رو نشون نمیده . مثلا من از زمینه دلخواه اول و سوم استفاده کردم. تمام کدهایی که گفته بودید را در فانکشنز و ادمین گذاشتم و در قالب هم


<a href="<?php echo $ax; ?>" class="zoom lightview">

برای مسیر عکس که بگیرد و


<?php echo $link; ?>

برای یک نوشته گذاشتم.چرا در سایت نمایش نمیدهد؟

کد کامل قسمتهایی که در قالب اسفاده کرده ام:


<?php
$my_query = new WP_Query('showposts=4&cat=3');
while ($my_query->have_posts()):
$my_query->the_post();
$do_not_duplicate = $post->ID;?>
<div class="span3">
<div class="feature_box">
<div class="feature_icon"><a href="<?php the_permalink() ?>"><?php if(has_post_thumbnail()) {the_post_thumbnail();} else {echo '<img class="attachment-post-thumbnail" src="'.get_bloginfo("template_url").'/images/no-img.jpg" />';}?>
</a></div>
<div class="feature_content">
<div class="feature_heading">
<div class="medium"><?php the_title(); ?></div>
<div class="large">
<?php echo $link; ?></div>
</div>
<p class="feature_desc"><?php the_content_rss('', TRUE, '', 60); ?></p>
</div>
<div class="feature_link"><a href="<?php the_permalink() ?>" class="arrows_icons16 icon16_5 more" title="بیشتربدانید"></a></div>
</div>
</div>
<?php endwhile; ?>


<ul id="foo2">
<?php
$my_query = new WP_Query('showposts=20&cat=4');
while ($my_query->have_posts()):
$my_query->the_post();
$do_not_duplicate = $post->ID;?>
<li>
<div class="pic-portfolio span4">
<div class="img"><a href="<?php the_permalink() ?>"> <?php if(has_post_thumbnail()) {the_post_thumbnail();} else {echo '<img class="attachment-post-thumbnail" src="'.get_bloginfo("template_url").'/images/no-img.jpg" />';}?>
</a></div>
<div class="img-hover"><span><?php the_title(); ?></span><a href="<?php the_permalink() ?>" class="link"></a><a href="<?php echo $ax; ?>" class="zoom lightview"></a></div>
</div>
</li>
<?php endwhile; ?>

</ul>

به اشتراک گذاری این پست


لینک به پست

شما از تابع get_post_meta استفاده نکردید

به اشتراک گذاری این پست


لینک به پست

شما از تابع get_post_meta استفاده نکردید

درکجا باید استفاده کنم؟میشه کامل بگید. من مبتدی ام

به اشتراک گذاری این پست


لینک به پست

شما باید با تایعی که پارسا گفته، مقدار زمینه رو در متغییر $link بریزید و بعد نمایش بدید.

به اشتراک گذاری این پست


لینک به پست

تابع get_post_meta برای خواندن زمینه هست

در همان تاپیک مثال گفته شده است

به اشتراک گذاری این پست


لینک به پست

تابع get_post_meta برای خواندن زمینه هست

در همان تاپیک مثال گفته شده است

دوخط زیر را هم زیر<?php get_header(); ?>اضافه کردم ولی باز نمایش نمیده:

<?php $link= get_post_meta($post->ID, "link", true); ?>

<?php $ax= get_post_meta($post->ID, "ax", true); ?>

ویرایش شده در توسط farnaz

به اشتراک گذاری این پست


لینک به پست

کد را در کد بالا بعد از while قرار دهید

به اشتراک گذاری این پست


لینک به پست

کد را در کد بالا بعد از while قرار دهید

میشه بگید چی بنویسم؟

به اشتراک گذاری این پست


لینک به پست

همون کدی که در پست 6 قراردادید

در مورد استفاده از زمینه دلخواه در انجمن زیاد بحث شده. جستجو کنید

به اشتراک گذاری این پست


لینک به پست


<?php $link= get_post_meta($post->ID, "link", true); ?>
<?php $ax= get_post_meta($post->ID, "ax", true); ?>

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط behi13
      با سلام
      دوستام و اساتید محترم یک سوال
      من به سایت دوزبانه با افزونه wpml درست کردم الان یک مشکل هست توی گوگل صفحه اول سایت ایندکس شده و توی فارسی مشکلی ندارم
      ولی توی زبان انگلیسی وقتی توی گوگل به انگلیسی سرچ میکنم بازهم با نام و فارسی میاد
      ممنون میشم من و راهنمایی کنید
    • توسط j1989m
      سلام
      توی قسمت افزودن نوشته و از طریق پرونده های رسانه ای یه عکس انتخاب میکنم و منتشر میکنم. توی سایت عکس رو نشون میده اما این کدها رو هم میاره:
      [caption id="attachment_154" align="aligncenter" width="300"] [/caption]
      درواقع عکس بین دوتا caption بالا قرار میگیره.
      این مشکل توی افزودن برگه نیست.
      لطفا راهنمایی کنید
      خیلی فوریه
      ممنون
    • توسط xboby
      سلام،
      من سایتی با ورد پرس طراحی کردم و می خواهم با:
      یک برنامه تمام پستهای موجود در کانال تلگرامی که بنام آن سایت ایجاد کر ده ام را
      بتوانم از موبایلم دانلود کنم و بعد در آن سایت قرار دهم:
      آیا چنان برنامه ای وجود دارد؟ لطفا راهنمائی ام بفرمائید.
                                   متشکرم
    • توسط دکتر مهندس
      سلام
      من چندتا سایت دارم که همه رو وقتی خواستم به وردپرس 4.7 ارتقا بدم، همگی مشکل دار شدند.
      به این صورت که خود سایت باز میشه اما قسمت مدیریت سایت باز نمیشه و لینکهای بخش مدیریت به این صورت میاد: /wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F
       
      توی صفحه هم که میاد اینطوری مینویسه: 
       
      The www......ir page isn’t working
      www.......ir is currently unable to handle this request.
      HTTP ERROR 500
    • توسط hessam75
      سلام
      من یه سایت با غالب be theme طراحی کردم فقط یه مشکل داره اونم اینه که پس زمینه رو پارالاکس انتخاب کردم ولی تو مرورگر internet xplorer پارالاکس نمایش داده نمیشه!
      در ضمن قالبم هم پول دادم از سایت معتبری خریدم ازین دانلودی ها نیست.
      لطفا کمک کنید بتونم رفع اشکال کنم.
      آدرس سایت : senateb.com