KAJOOSH

مشکل همزمان با 2 دامنه

26 پست در این موضوع قرار دارد

سلام

یک مشکل فنی سایته تازه تاسیسم داره اینکه با دامنه اصلی هیچگونه مشکلی در لود سایت وجود نداره

اما

2 دامنه دیگه پارک کردم،اما بعد از لود شدن سایت،فون های سایت به هم ریخته نشون داده میشه ... (دامنه پارک شده)

لینک اصلی سایت >>>

لینک دوم ( پارک شده ) >>>

0

به اشتراک گذاری این پست


لینک به پست

برای من هیچ مشکلی نداشت.هر دو سایت به راحتی باز میشوند.

0

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

بله باز که میشه ...

فونت هاش باهم تفاوت داره ... !

دامینی که پارک شده فونت هاش به درستی نشان داده نمیشه ..!

از چه مرورگری استفاده کردید ..!؟ اگر کروم استفاده میکنید،آره درست نشون میده .. اما تو فایرفاکس خیر ... :(

ویرایش شده در توسط KAJOOSH
0

به اشتراک گذاری این پست


لینک به پست

درود

من با فایرفاکس هردو سایت رو چک کردم تفاوتی باهم نداشتند!

0

به اشتراک گذاری این پست


لینک به پست

شاید مشکل از کَش isp شما باشه!

هر دو یکسان هست

0

به اشتراک گذاری این پست


لینک به پست

سلام

متعصفانه این چند روزی که من نبودم،دامنه (پارک شده) رو ریدایرکت کردم روی دامنه اصلی

الان باز دامنه رو فقط پارک کردن لطفا الان مشاهده کنید .. (فقط با کروم فونت ها خوب نشون میده)

لینک اصلی سایت >>>

لینک دامنه پارک شده >>>

0

به اشتراک گذاری این پست


لینک به پست

هیچ کدوم از دوستان دردش رو نفهمیدید ؟ :| :(

0

به اشتراک گذاری این پست


لینک به پست

فونت ها رو بصورت کامل از سایت اصلی آدرس دهی کنید درست میشه

0

به اشتراک گذاری این پست


لینک به پست

هرچی بررسی میکنم فایل style.css

مشکلی نداره آخه :(


@font-face {
font-family: 'BKoodak';
src: url('fonts/BKoodakBold.eot?#') format('eot'), /* IE6?8 */
url('fonts/BKoodakBold.woff') format('woff'), /* FF3.6+, IE9, Chrome6+, Saf5.1+*/
url('fonts/BKoodakBold.ttf') format('truetype'); /* Saf3?5, Chrome4+, FF3.5, Opera 10+ */
}

body {

-moz-font-smoothing: antialiased;
-webkit-font-smoothing: antialiased;
background: #efefef;
color: #555;
font-family: BKoodak;
font-size: 14px;
font-smoothing: antialiased;
line-height: 1.5em;
text-rendering: optimizeLegibility;

0

به اشتراک گذاری این پست


لینک به پست

با آدرسدهی مستقیم تست کنید

@font-face {
font-family: 'BKoodak';
src: url('http://www.skhm.ir/wp-content/themes/responsive/fonts/BKoodakBold.eot?#') format('eot'), /* IE6?8 */
url('http://www.skhm.ir/wp-content/themes/responsive/fonts/BKoodakBold.woff') format('woff'), /* FF3.6+, IE9, Chrome6+, Saf5.1+*/
url('http://www.skhm.ir/wp-content/themes/responsive/fonts/BKoodakBold.ttf') format('truetype'); /* Saf3?5, Chrome4+, FF3.5, Opera 10+ */
}

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

الان من 3 دامنه دیگه دارم که باید واسه هر کدام دامنه ها آدرس دهی کنم به این صورت :


/// دامنه اصلی: ///

@font-face {
font-family: 'BKoodak';
src: url('fonts/BKoodakBold.eot?#') format('eot'), /* IE6?8 */
url('fonts/BKoodakBold.woff') format('woff'), /* FF3.6+, IE9, Chrome6+, Saf5.1+*/
url('fonts/BKoodakBold.ttf') format('truetype'); /* Saf3?5, Chrome4+, FF3.5, Opera 10+ */

/// دامنه پارک شده با www : ///
}

@font-face {
font-family: 'BKoodak2';
src: url('http://www.skh72x.ir/wp-content/themes/responsive/fonts/BKoodakBold.eot?#') format('eot'), /* IE6?8 */
url('http://www.skh72x.ir/wp-content/themes/responsive/fonts/BKoodakBold.woff') format('woff'), /* FF3.6+, IE9, Chrome6+, Saf5.1+*/
url('http://www.skh72x.ir/wp-content/themes/responsive/fonts/BKoodakBold.ttf') format('truetype'); /* Saf3?5, Chrome4+, FF3.5, Opera 10+ */
}

/// دامنه پارک شده بدون www : ///
.
.
.
.



body {

font-family: BKoodak, BKoodak2;

تازه آدرس پارک شده بدون www باز نمیتونه فونت رو فراخوانی کنه :| (که باید جداگانه تعریف بشه)

اینجوری که واسه 3 دامنه پارک شده باید 6 بار فونت مثل هم تعریف بشه که هم سخته :) هم از سرعت بارگزاری سایت خیلی کاهش پیدا میکنه ...

موردی دیگه سراغ ندارید ؟!

ویرایش شده در توسط KAJOOSH
0

به اشتراک گذاری این پست


لینک به پست

درود

فقط یه بار باید اینکار رو بکنی تو کد css قالبتون آدرس کامل بدید به فونت ها از همون دامنه اصلیتون:


@font-face {
font-family: 'BKoodak2';
src: url('http://www.skh72x.ir/wp-content/themes/responsive/fonts/BKoodakBold.eot?#') format('eot'), /* IE6?8 */
url('http://www.skh72x.ir/wp-content/themes/responsive/fonts/BKoodakBold.woff') format('woff'), /* FF3.6+, IE9, Chrome6+, Saf5.1+*/
url('http://www.skh72x.ir/wp-content/themes/responsive/fonts/BKoodakBold.ttf') format('truetype'); /* Saf3?5, Chrome4+, FF3.5, Opera 10+ */
}

فک کنم این کافی باشه!

2

به اشتراک گذاری این پست


لینک به پست

ارسال شده در (ویرایش شده)

تست کردم داداش ...

اما فقط با همین دامنه فوف فونت فراخوانی میشه ...!

با دامنه اصلی و اون یکی دامنه پارک شده فراخواخنی نمیشه ..! :(

ویرایش شده در توسط KAJOOSH
0

به اشتراک گذاری این پست


لینک به پست

الان که سایت اف هست و چیزی نمیشه گفت

0

به اشتراک گذاری این پست


لینک به پست

در حال بروز رسانی قالب به ورژن 1.9 بودم

الان سایت در دسترس میباشد و همچنان این مشکل پا برجاست

0

به اشتراک گذاری این پست


لینک به پست

الان پارک هست یا ریدایرکت؟ چون هر دو به یک دامنه میرن

0

به اشتراک گذاری این پست


لینک به پست

دامنه پارک شده است ..!

منوها به دامنه اصلی ریدایرکت میشد که اصلاح گردید.

دامنه پارک شده >>>

عجب مرضی پیدا کرده این سایت ما ... بعد این همه دکتر و دوا هنو حالش خوب نشده :دی :)

ویرایش شده در توسط KAJOOSH
0

به اشتراک گذاری این پست


لینک به پست

الان که مشکلی نیست فقط دامنه http://www.skh72x.ir/ کلا میره به دامنه http://www.skhm.ir/

0

به اشتراک گذاری این پست


لینک به پست

شما توی فایل استایل آدرس دهی مستقیم برای فونت ها انجام ندادید.

توی چند پست قبلتر گفته بودم.

0

به اشتراک گذاری این پست


لینک به پست

داداش من .. انجام داده بودم و تست کردم اما جواب نگرفتم و دوباره به صورت قبل برش گردوندم

0

به اشتراک گذاری این پست


لینک به پست

همون شیوه درست هست.

میتونید روی کروم تست کنید و نتیجه رو ببینید.

اینها رو به فایل htaccess اضافه کنید:

AddType application/vnd.ms-fontobject .eot
AddType font/ttf .ttf
AddType font/otf .otf
<FilesMatch "\.(ttf|otf|eot)$">
<IfModule mod_headers.c>
Header set Access-Control-Allow-Origin "*"
</IfModule>
</FilesMatch>

8

به اشتراک گذاری این پست


لینک به پست

وای ی ی

درست شد د د د ( تو موزیلا هم ج داد ) <3 <3 <3

خیلی خیلی ممنون Morteza :* جان

0

به اشتراک گذاری این پست


لینک به پست

چرا توی فایر فاکس درست نشون نمیده ؟

1

به اشتراک گذاری این پست


لینک به پست

چرا توی فایر فاکس درست نشون نمیده ؟

روش گفته شده رو تست کردید؟

1

به اشتراک گذاری این پست


لینک به پست

بله تست کردم نشد !

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط pouyamahmoudi
      با عرض سلام ، وقت بخیر و خسته نباشید
      قالب وردپرس من با وجود واکنش گرا بودن در نسخه موبایل یک مشکل داره 
      مشکل اینه که به صورت یه صفحه خالی با رنگ پس زمینه سایت میاد و باید صفحه رو بکشم به سمت راست تا محتویات نمایش داده بشه 
      لطفا جهت حل این مشکل راهنمایی کنید
      با سپاس

    • توسط arianemun
      سلام عرض ادب به کاربران وردپرس پارسی ، من یک مشکلی دارم در افزونه ای ، افزونه woocomerce product finder یک افزونه ای است طبق تنظیمات و چیز هایی که برای محصول ووکامرسی تعریف میکنیم با انتخواب گزینه ها توسط کاربر محصول مورد نظر خودش رو پیدا میکنه، تنها مشکلی که این افزونه یا میشه گفت ضعفی که داره تفاوت محصول برجسته رو با محصول ساده متوجه نمیشه یعنی اگر تو اون دسته یک محصول برجسته باشه و یک محصول ساده اون ها رو از هم تفکیک نمیکنه من میخواستم این قابلیت رو به این افزونه اضافه کنم که کاربر وقتی محصولش رو پیدا کرد هم محصول ساده ها رو ببینه و محصول برجسته شده ! ممنون میشم کمک کنید .
       
      لینک افزونه استفاده شده
    • توسط reza_yki
      سلام من ابزارکی نوشتم که کاربر بتونه به وسیله select option به صورتی multi بتونه چندین دسته رو انتخاب کنه همه چیز درست و بدون مشکل کار میکنه فقط یه مشکل هست اونم اینه که وقتی ابزارک رو برای اولین بار فعال میکنی خطای زیر رو میده وباید یه دونه دسته رو انتخاب و ذخیره کنی تا ابزارک به صورت صحیح کارکنه لطفا راهنماییم کنید.
      Warning: in_array() expects parameter 2 to be array, string given in E:\Program Files\xampp\htdocs\wordpress\wp-content\themes\mymag\functions\widgets\widgets.php on line 29  
      اینم سورس کد:
      <?php public function form( $instance ) { $title = ! empty( $instance['title'] ) ? $instance['title'] : esc_html__( 'عنوان ابزارک', 'text_domain' ); $args = array( 'hide_empty' => 0, 'type' => 'post', 'taxonomy' => 'category', 'orderby' => 'name', 'hierarchical' => true, ); $cats = get_categories( $args ); $instance['cat_id'] = isset( $instance['cat_id'] ) ? ( $instance['cat_id'] ) : '1'; $count_cat = isset ($instance['cat_id']) ? count($instance['cat_id']) : '1' ; $tab_number = isset( $count_cat ) ? absint( $count_cat ) : 1; ?> <p> <label for="<?php echo $this->get_field_name( 'title' ); ?>"><?php _e( 'Title:' ); ?></label><br> <input class="widefat" id="<?php echo $this->get_field_id( 'title' ); ?>" name="<?php echo $this->get_field_name( 'title' ); ?>" type="text" value="<?php echo esc_attr( $title ); ?>" /> </p> <p> <label for="<?php echo $this->get_field_id('tab_number'); ?>"><?php _e( 'تعداد زبانه:'); ?></label><br> <input id="<?php echo $this->get_field_id('tab_number'); ?>" name="<?php echo $this->get_field_name('tab_number'); ?>" type="number" min="0" class="my_widget_number" value="<?php echo $tab_number; ?>" size="3" /> </p> <label for="<?php echo $this->get_field_name( 'cat_id' ); ?>"><?php _e( 'انتخاب دسته بندی : ' ); ?></label> <select id="<?php echo $this->get_field_id( 'cat_id' ); ?>" name="<?php echo $this->get_field_name( 'cat_id[]' ); ?>" multiple="multiple" style="width: 100%; margin: 10px auto; height: auto;"> <?php foreach( $cats as $cat ): ?> <option value="<?php echo esc_attr(__($cat->term_id)); ?>"<?php selected(in_array($cat->term_id, $instance['cat_id'])); // selected($cat->term_id,$cats_id) ?>><?php echo esc_attr(__($cat->name)); ?></option> <?php endforeach; ?> </select> <p> <input type="text" value="<?php echo esc_attr(__(implode(',', $instance['cat_id']))); ?>"> </p> <?php }  
    • توسط سعید فرزادی پور
      با عرض سلام
      من به مشکلی خوردم که راه حل اون رو نمیدونم
      در هدر سایت یک نویگیشن بار دارم که منوی اصلی سایتم به صورت دراپ داون در این نویگیشن بار وجود داره ، قال سایت من shaply هستش و استفاده از ویجت ها در body بازه ، من با استفاده از یک ویجت اسلایدر در بالاترین قسمت و زیر هدر سایت که ارتفاع اونم 55 پیکسل هستش اسلایدر بزرگ ایجاد کردم ، و حالا زمانی که میرم روی دراپ داون ها متاسفانه تا قبل از اسکرول کردن به پایین ، زیر منو ها به زیر اسلایدر میرن ، اما بعد از اسکرول کردن به پایین این مشکل حل شده و منو ها و زیر منو ها نمایش داده میشن ، هرچه z-index رو افزایش دادم نتیجه ای نداشت ، چطور میتونم این مشکل رو حل کنم ؟
      و سوال دوم این که در این تم منو ها اول به پایین و بعد به راست باز میشن و من میخوایم سایت رو به صورت فارسی داشته باشم و میخوام اول به پایین و بعد به چپ باز بشن منو ها , چه تغییری میتونم در css ایجاد کنم ؟
    • توسط hamid_diablo
      سلام دوستان
      من وردپرس رو روی لوکال هاست نصب کرده بودم
       
      تا چند روز پیش مشکلی نداشتم تا اینکه یه پوسته جدید نصب کردم و بعد از اون متاسفانه وردپرس بالا نیامد (صفحه سفید ظاهر شد )
       
      فقط قالب صحیفه رو نمایش میده بدون پیشخوان!!!
       
      وردپرس و پاک کردم و دوباره روی لوکال هسات نصب کردم اما مشکل برطرف نشد !
      ممنون میشم راهنماییم کنید