ShikA

سوال در مورد تصویر شاخص

11 پست در این موضوع قرار دارد

برای قرار دادن تصویر شاخص حتما باید اون تصویر توی هاست آپلود شده باشه و از اونجا فراخوانی بشه؟

نمیشه کدی داد بش که مثلا هر عکسی که توی اون پست یا مطلب قرار داره رو بعنوان تصویر شاخص قرار بده؟

به اشتراک گذاری این پست


لینک به پست

تصویر شاخص باید روی هاست خودتون باشه اما منظورتون از بخش دوم مشخص نیست. مطلب بصورت اتوماتیک کپی میشه از سایتهای دیگه یا خودتون میذارین و میخواین خودکار عکسی رو به نوان تصویر شاخص معرفی کنه؟

به اشتراک گذاری این پست


لینک به پست

بله میخوام بدون اینکه خودم آپلود کنم عکس رو مثلا عکس هارو از جایی کپی کردم و میخوام اون عکس رو به عنوان تصویر شاخص قرار بدم ........ امکانش هست؟؟

به اشتراک گذاری این پست


لینک به پست

برای لود اولین عکس

تصویر پیوست به عنوان شاخص

ذخیره تصاویر به عنوان شاخص:


http://wordpress.org/extend/plugins/media-tools/

به اشتراک گذاری این پست


لینک به پست

مرسی از کمک ها و راهنمایی های عزیزان

من کارهای توی آموزش تصاویر شاخص در وردپرس یکبار برای همیشه رو انجام دادم ...

آموزش هایی رو هم که پارسا جان گذاشته بود رو هم انجام دادم اما توی هر دو حالت عکس تصویر شاخص رو بازم نشون نمییده!

اما بازم تصویر No img رو نشون میده توی مطالب که تصویر شاخص نذاشتم

البته نمیدونم من تونستم مشکلم رو بگم یا نه .....

من همین جوری میتونم تصویر شاخص بذارم فقط باید توی هاست آپ کنم تا نشون بده!

اما من میخوام بدون آپلود کردن کد عکس توی اون مطلب اتوماتیک بره روی تصویر شاخص و اون رو نشون بده

ویرایش شده در توسط ShikA

به اشتراک گذاری این پست


لینک به پست

مشکل نشون دادن عکس ها حل شد ... فقط دو مورد هست!!

1- بعضی مطالب که خودم تصویر شاخص براشون گذاشتم رو نشون نمیده! ( فقط یه تعداد خیلی کمی 2-3 تا ) نمیدونم چرا!!!!!!!!

2- اندازه تصویر رو هرکاری کردم تغییر نکرد!

به شکل زیر نشون میده در هر حالت!!

Casde.jpg

اینم کد این باکس ...

<div class="boxed">
<div class="ctitle">
<div class="boxed-image" style="background-image: url('<?php bloginfo('template_url'); ?>/img/<?php echo $cat_img[$rnd]; ?>');"></div><h1>
<span class="link"><?php echo $cat_name[$rnd]; ?></span></h1>
<span class="rss"><a href="<?php bloginfo('url'); ?>/category/<?php echo $cat[$rnd]; ?>/"><img src="<?php bloginfo('template_url'); ?>/img/rss.png" alt="rss"></a></span></div>
<div class="content">
<?php $recent = new WP_Query("category_name=".$cat[$rnd]."&showposts=1"); while($recent->have_posts()) : $recent->the_post();?>
<div class="description">
<div class="link"><a href="<?php the_permalink(); ?>" class=""><?php the_title(); ?></a></div>
<div class="img">
<a href="<?php the_permalink(); ?>"><?php if(has_post_thumbnail()) {the_post_thumbnail();} else {echo '<img src="'.get_bloginfo("template_url").'/img/no-image.gif" />';}?></a><?php the_content_rss('', TRUE, '', 50); ?>
</div>
</div>
<?php endwhile; ?>
<ul id="block-link" style="height: 140px;">
<?php $recent = new WP_Query("category_name=".$cat[$rnd]."&showposts=7"); while($recent->have_posts()) : $recent->the_post();?>
<li><a href="<?php the_permalink(); ?>" class="tt" title="<?php the_title(); ?>"><?php the_title(); ?></a></li>
<?php endwhile; ?>
</ul>
<div style="clear: both;"></div>
<div class="boxed-archive"><a href="<?php bloginfo('url'); ?>/Category/<?php echo $cat[$rnd]; ?>/"><img src="<?php bloginfo('template_url'); ?>/img/archive.png" alt="archive"></a></div>
</div>
<div class="footer"> </div>
</div>

به اشتراک گذاری این پست


لینک به پست
1- بعضی مطالب که خودم تصویر شاخص براشون گذاشتم رو نشون نمیده! ( فقط یه تعداد خیلی کمی 2-3 تا ) نمیدونم چرا!!!!!!!!

دستی در هر پست تصویر شاخص وارد کردید یا اینکه از ادرسی که ینده دادم استفاده کردید؟

2- اندازه تصویر رو هرکاری کردم تغییر نکرد!

هم میتونید در استایل بهش اندازه بدید و اینکه در بخش تنظیمات رسانه اندازه رو مشخص کنید

به اشتراک گذاری این پست


لینک به پست

هر دو رو امتحان کردم

البته من بخاطر این تصویر شاخص کلی کار انجام دادم شاید قاطی پاتی شده واسه همون!

با هیچ کدوم از این روش ها نتونستم انجام بدم ... بازم no image مینوشت توی مطالب که تصویر شاخص نداشتن

بعد از نصب افزونه Add Linked Images To Gallery مطالبی که تصویر شاخص نداشتن ( عکس هاشون کپی شده از جای دیگه بودن ) دارای تصویر شاخص شدن ولی اینجوری کشیده نشون میده عکس هارو !!

این مشکل توی صفحه اصلی index هستش!! توی صفحات داخلی کشیده نشون نمیده!

به اشتراک گذاری این پست


لینک به پست

مشکل از استایل هست احتمالا

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری