silver21

مشکل با بخش گالری تصاویر Link to : media file

13 پست در این موضوع قرار دارد

وقتی از گالری وردپرس جدید 3.5.1 استفاده میکنم و عکسهارو هم تعریف میکنم که 2 یا 3 ستونه باشه و link to نیز پیشفرض روی media file قرار داره تصاویر با هیچکدام از light box ها باز نمیشه و به صفحه دیگه ای میره ؛ دلیلشم متوجه شدم : باید یکبار link to رو روی برگه پیوست بذارم و مجدد روی media file | ظاهرا زمانی که پیشفرض روی media file قرار داره درست عمل نمیکنه ، چیکارش کنم؟

0

به اشتراک گذاری این پست


لینک به پست

اول اینکه در تنظیمات افزونه باید Use For WordPress Galleries رو فعال کنید

و فرمت فراخوانی گالری در پست ها به صورت زیر باشه:


[gallery link="file" ids="7,8,9,10,11,12"]

1

به اشتراک گذاری این پست


لینک به پست

Use For WordPress Galleries فعاله و در وردپرس 3.4.2 مشکلی نداشتم .

نگاه کنید وقتی حالت link to رو یکبار قرار میدم رو حالت پیوست به برگه و همون لحظه برمیگردونم روی media file درست میشه. ظاهرا بایستی سه حالت تعریف میشد : (هیچکدام | media file | پیوست به برگه ) چون در ابتدا وقتی رو حالت media قرار داره هیچ دستوری اعمال نمیشه و باید یکبار گزینه ها رو جابجا کرد.

0

به اشتراک گذاری این پست


لینک به پست

در وردپرس 3.5.1 فقط دو گزینه ی پوسته پیوست و فایل وجود داره

کدی رو که در پست برای گالری قرار میگیره از تب متن (html) اینجا قرار بدید.

0

به اشتراک گذاری این پست


لینک به پست


[gallery ids="1495,1486,1479,1478"]
 
[gallery link="file" ids="1495,1486,1479,1478,1487,1483"]

اولی رو گالری انتخاب کردم عکسارو add و ثبت گالری ( گزینه link to در حالت پیشفرض روی media file بود )

و دومی ( زمان گذاشتن گالری link to رو یه لحظه رو پیوست برگه گذاشتم و مجددا برگردوندم به media file )

باید یه گزینه دیگه هم میذاشتن یا اینکه در همون حالت اولیه کاری میشد که media file یه دستوری رو اجرا کنه ولی عملا بیکار وایستاده.

0

به اشتراک گذاری این پست


لینک به پست

دومی باید درست عمل کنه

0

به اشتراک گذاری این پست


لینک به پست

لینک

100 % دومی درسته ولی میگم باید موقع ارسال باید گزینه link to رو از حالت media file بذارم رو پیوست برگه و دوباره برگردونم رو media file تا کار کنه - چرا؟ چرا اینطوریه؟

0

به اشتراک گذاری این پست


لینک به پست

بعضا در بروزرسانی های خودکار مشکلاتی در وردپرس پیش میاد.

شما هم بروزرسانی خودکار کردید؟

0

به اشتراک گذاری این پست


لینک به پست

فولدر wp-contact , فایل wp-config.php و .htaccess و دیتابیس رو نگه داشتم و بجز این موارد فایلها و فولدر های wp 3.5.1 رو اضافه کردم - هنگام لود سایت پرسیده شد بروزرسانی انجام داد .

همه بخشها و موارد بی عیب و نقصه جز این مورد

0

به اشتراک گذاری این پست


لینک به پست

احتمالا بیربطه ولی اینکار رو انجام بدید:

همه افزونه ها -> غیرفعال

پوسته پیش فرض رو فعال کنید.

ببینید تغییری میکنه؟

0

به اشتراک گذاری این پست


لینک به پست

همه افزونه ها -> غیرفعال

پوسته پیش فرض فعال شد.

تغییری نکرد.


[gallery ids="1487,1486,1483,1484"]

0

به اشتراک گذاری این پست


لینک به پست

میتونید راهنمایی کنید که یه گزینه هیچکدام" هم بهش اضافه کنم که پیشفرض روش باشه| کدوم فایل ویرایش کنم

0

به اشتراک گذاری این پست


لینک به پست

در پوشه wp-includes در فایل media-template برسی کنید

0

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری