حسین

مشکل افزونه Lazy Load با نسخه موبایل

4 پست در این موضوع قرار دارد

سلام من افزونه Lazy Load رو نصب کردم ولی با نسخه موبایل موشکیل داره.

لامصب افزونه ای نیست که به خاطر این مشکل بشه ازش گذشت. لطفا راهنمایی کنید توی نسخه موبایل از کار بندازم این افزونه رو :ph34r:

0

به اشتراک گذاری این پست


لینک به پست

میتونید براساس سیستم موبایل در جاواسکریپت عمل کنید:

var userAgent = navigator.userAgent;

if (userAgent.match(/iPad/i) || userAgent.match(/iPhone/i)) {
// iPad or iPhone
}
else {
// Anything else
}

باید لودر جاواسکریپت افزونه Lazy Load رو در کدبالا قرار بدید.

البته با php هم میشه.

منبع

1

به اشتراک گذاری این پست


لینک به پست

ببخشید متوجه نشدم!

الان توی افزونه این تابع هست: LazyLoad_Images::init(); که خودکار برای وردپرس بارگزاری می کنه.

الان می شه اینو از اینجا بردارم و توی قالب مورد نظرف فقط بذارم؟

0

به اشتراک گذاری این پست


لینک به پست

اگر تابعش همچین چیزی هست اینرو تست کنید:


var userAgent = navigator.userAgent;

if (userAgent.match(/iPad/i) || userAgent.match(/iPhone/i)) {
// nothing for iPad or iPhone
}
else {
LazyLoad_Images::init();
}

باید بجای تابع فراخوانی در اسکریپت قرار بگیره. البته کد بالا برای آیفون و آی پد کار میکنه.

برای بقه دستگاه ها باید اسم agent رو پیدا و جاگذاری کنید.

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری