pary_daryayi

مشکل با title در وردپرس

13 پست در این موضوع قرار دارد

سلام . من یه سایت روی هاست با وردپرس گذاشتم .

1 ) وقتی سایت بالا میاد برای یک لحظه ی کوتاه عبارتی که در title هست رو نشون میده و بعد از بین میره . علت چیه ؟ برای دوتای قبلی اینطور نبود .

البته اینبار از wp_head() هم استفاده کردم . یک بار هم title رو مستقیم گذاشتم ولی باز همین اتفاق افتاد .

2 ) و یک سوال دیگه . بعنوان مثال اگر در title داشته باشم " وب سایت شخصی پری " بعد از گذشت چه مدت از قرار دادن سایت روی وب با تایپ عبارت title در گوگل ، وب سایتمون تو صفحات اول گوگل میاد .

برای این سایت با تایپ دقیق عبارت title ، در صفحه ی اول ،‌دوم و ... وب سایت رو نشون نمیده . علت به خاطر همین مشکلی هست که پیش اومده ؟

ممنون

0

به اشتراک گذاری این پست


لینک به پست

سلام . من یه سایت روی هاست با وردپرس گذاشتم .

1 ) وقتی سایت بالا میاد برای یک لحظه ی کوتاه عبارتی که در title هست رو نشون میده و بعد از بین میره . علت چیه ؟ برای دوتای قبلی اینطور نبود .

البته اینبار از wp_head() هم استفاده کردم . یک بار هم title رو مستقیم گذاشتم ولی باز همین اتفاق افتاد .

2 ) و یک سوال دیگه . بعنوان مثال اگر در title داشته باشم " وب سایت شخصی پری " بعد از گذشت چه مدت از قرار دادن سایت روی وب با تایپ عبارت title در گوگل ، وب سایتمون تو صفحات اول گوگل میاد .

برای این سایت با تایپ دقیق عبارت title ، در صفحه ی اول ،‌دوم و ... وب سایت رو نشون نمیده . علت به خاطر همین مشکلی هست که پیش اومده ؟

ممنون

درود ...

برای قرار دادن title در وردپرس شما میتونید به تنظیمات همگانی خود وردپرس رفته و سپس در قسمت معرفی کوتاه، متن خودتون رو وارد کنید و سپس گزینه بروزرسانی رو بزنید.

برای اینکه وبسایت شما با سرچ کلمات مربوط به مطالب وبسایتتون و یا عناوین انتخابی شما در گوگل نمایش داده بشه، شما باید روی سئو وبسایتتون کار کنید. ( در مورد سئو هم در این انجمن مطالب زیادی هستش که با سرچ کردن میتونید پیداشون کنید و بررسی نمایید. )

:)

3

به اشتراک گذاری این پست


لینک به پست

1- فایل هدر رو اینجا پیوست کنید.

همچنین کل افزونه ها رو غیرفعال و مجدد تست کنید

با پوسته پیش فرض درست هست؟

2- برای این مورد زمان و مهمتر از اون ورودی و ایندکس سایتتون مهم هست و این ها هست که مشخص میکنه سایتتون در چه صفحه ایی از گوگل قرار بگیره

2

به اشتراک گذاری این پست


لینک به پست

بله در تنظیمات همگانی هم وارد کردم . تحت لوکال درست کار میکنه روی هاست این اتفاق میفته.

-----------------

من در تنظیمات همگانی عنوان سایت رو وارد کردم . با پوسته ی پیش فرض که تست میکنم یک عنوانی که قبلا گذاشته بودم و تغییر داده بودم رو داره نشون میده . !!!!!!!!!!!!! و بعد از چند ثانیه از بین نمیره.

ولی با پوسته ی پیش فرض اگر فقط wp_head() باشه چیزی نشون نمیده و اگر خودم یک title دستی بزارم یک لحظه ی کوتاه عنوانی که در title دستی وارد کردم رو نشون میده و از بین میره.

این هم فایل . ممنونم ازتون .

0

به اشتراک گذاری این پست


لینک به پست

فکر میکنم فهمیدم مشکل به خاطر چیه اما راه حل رو نمیدونم . من افزونه ی All in one seo رو هم نصب کردم و اونجا یک عنوان دیگه ای نوشته بودم و در تنظیمات همگانی یک عنوان دیگه . الان هر دو رو یکی کردم ولی باز نشون نمیده ولی با پوسته ی اصلی مشکلی نداره الان .

فکر میکنم به خاطر تداخل این افزونه باشه . البته افزونه رو غیر فعال که کردم تاثیری نداشت و درست نشد.

وقتی view source رو میبینم هیچ تگ متایی وجود نداره و همینطور title

ویرایش شده در توسط pary_daryayi
0

به اشتراک گذاری این پست


لینک به پست

دوستان فهمیدم ، مشکل به خاطر wp_head هست که اگه حذف بشه این مشکل پیش نمیاد . ولی به wp_head‌ به خاطر کار کردن افزونه ی نظرسنجی wp_polls نیاز دارم ، راهی برای رفع این مشکل هست ؟

0

به اشتراک گذاری این پست


لینک به پست

با wp_head چه چیزهایی چاپ میشوند؟

افزونه ها را غیر فعال و تست کنید

2

به اشتراک گذاری این پست


لینک به پست

کل افزونه ها رو غیر فعال کنم ؟

اگر افزونه ی all in seo رو غیر فعال کنم ؛ فقط با wp_head و بدون استفاده از توابع متا (lمثلا bloginfo('name')) اینو چاپ میکنه و یک سری تگ های link و script مربوط به بعضی افزونه ها . مثلا اسکریپت های مربوط به افزونه ی نظرسنجی


<meta name="generator" content="WordPress 3.5.1" />

ویرایش شده در توسط pary_daryayi
0

به اشتراک گذاری این پست


لینک به پست

پیشفرض تگ title را دارید؟

0

به اشتراک گذاری این پست


لینک به پست

ترتیب قرار دادن کدها رو به این صورت کردم و فعلا درست شد . قبلا wp_head رو بلافاصله بعد از تگ head میزاشتم ( فکر نمیکردم ترتیب مهم باشه )


<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8" />
<title><?php bloginfo('name'); ?><?php wp_title(); ?></title>
<meta name="description" content="<?php bloginfo('description'); ?>" />
<?php wp_head();?>

ویرایش شده در توسط pary_daryayi
0

به اشتراک گذاری این پست


لینک به پست

تابع wp_head باید قبل از تگ </head> باشد

1

به اشتراک گذاری این پست


لینک به پست

یعنی شما منظورتون اینه که دقیقا قبل از کد <head/> باشه ؟

یعنی اینطوری ؟


<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8" />
<title><?php bloginfo('name'); ?><?php wp_title(); ?></title>
<meta name="description" content="<?php bloginfo('description'); ?>" />
<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/stylesheet/estilo.css" type="text/css" media="screen" />
<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/stylesheet/jquery.fancybox.css?v=2.1.2" media="screen" />
<?php wp_head();?>
</head>

من اینطور نوشتم و درست شد :



<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8" />
<title><?php bloginfo('name'); ?><?php wp_title(); ?></title>
<meta name="description" content="<?php bloginfo('description'); ?>" />
<?php wp_head();?>
<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/stylesheet/estilo.css" type="text/css" media="screen" />
<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/stylesheet/jquery.fancybox.css?v=2.1.2" media="screen" />
</head>

ولی قبلا اینطور نوشته بودم :



<!DOCTYPE html>
<html>
<head>
<?php wp_head();?>
<meta charset="UTF-8" />
<title><?php bloginfo('name'); ?><?php wp_title(); ?></title>
<meta name="description" content="<?php bloginfo('description'); ?>" />
<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/stylesheet/estilo.css" type="text/css" media="screen" />
<link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/stylesheet/jquery.fancybox.css?v=2.1.2" media="screen" />
</head>

ویرایش شده در توسط pary_daryayi
0

به اشتراک گذاری این پست


لینک به پست

مشکلی نیست

بحث همون رعایت الویت هست

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری