i.gratia

ارور 404 اختصاصی برای یک دسته

2 پست در این موضوع قرار دارد

سلام و عرض خسته نباشید خدمت وی پی پارسیهای عزیز :

میخواستم بدونم میشه ارور 404 یه دسته خاص رو تغییر داد ؟؟؟

مثلا یه دسته ی خاص اگه مطلب نداشت یه ارور نمایش بده و یک دسته ی دیگر اگر پستی داخلش نبود یک ارور دیگر

0

به اشتراک گذاری این پست


لینک به پست

بله میشه

کافیه در همون فایل 404 از شرط با تابع in_category استفاده کنید

نمونه استفاده:

http://forum.wp-parsi.com/tutorials/article/174-%D8%A7%D8%B3%D8%AA%D8%A7%DB%8C%D9%84-%D8%AC%D8%AF%D8%A7-%D8%A8%D8%B1%D8%A7%DB%8C-%D8%A7%D8%AF%D8%A7%D9%85%D9%87-%DB%8C-%D9%85%D8%B7%D9%84%D8%A8/

1

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط سعید فرزادی پور
      با عرض سلام
      من به مشکلی خوردم که راه حل اون رو نمیدونم
      در هدر سایت یک نویگیشن بار دارم که منوی اصلی سایتم به صورت دراپ داون در این نویگیشن بار وجود داره ، قال سایت من shaply هستش و استفاده از ویجت ها در body بازه ، من با استفاده از یک ویجت اسلایدر در بالاترین قسمت و زیر هدر سایت که ارتفاع اونم 55 پیکسل هستش اسلایدر بزرگ ایجاد کردم ، و حالا زمانی که میرم روی دراپ داون ها متاسفانه تا قبل از اسکرول کردن به پایین ، زیر منو ها به زیر اسلایدر میرن ، اما بعد از اسکرول کردن به پایین این مشکل حل شده و منو ها و زیر منو ها نمایش داده میشن ، هرچه z-index رو افزایش دادم نتیجه ای نداشت ، چطور میتونم این مشکل رو حل کنم ؟
      و سوال دوم این که در این تم منو ها اول به پایین و بعد به راست باز میشن و من میخوایم سایت رو به صورت فارسی داشته باشم و میخوام اول به پایین و بعد به چپ باز بشن منو ها , چه تغییری میتونم در css ایجاد کنم ؟
    • توسط poruamohammady
      سلام دوستان من یه مدت هست افزونه هایی که نصب می کنم ورد پرس بهم این اخطار هار رو میده کسی میتونه کمک کنه برای مثال تازگی ها افزونهwp-super cacheرو که نصب کردم این اومد قبلا هم چیزای دیگه بود مرسی اگر راهنمایی کنید

    • توسط mehran-b
      با سلام و عرض ادب خدمت تمامی کاربران انجمن وردپرس پارسی
       
      امروز یک کدی براتون قرار میدم که با استفاده از این کد میتونید به تمامی پست های یه دسته خاص از وب سایتتون متای robots با مقدار noindex,follow اضافه کنید.
       
      در صورت نصب بودن افزونه سئو وردپرس
      add_filter('wpseo_robots', 'mehran_specific_category_posts_add_noindex_yoast'); function mehran_specific_category_posts_add_noindex_yoast($content) { if(is_single() && in_category(777)) { return "noindex,follow"; } return $content; } در صورت نصب نبودن افزونه سئو وردپرس
      add_action('wp_head', 'mehran_specific_category_posts_add_noindex'); function mehran_specific_category_posts_add_noindex() { if(is_single() && in_category(777)) { $output = '<meta name="robots" content="noindex,follow" />' . "\n"; } echo $output; }  
      توجه1: کدهای بالا رو باید در فایل functions.php قالب سایتتون و زیر اولین
      <?php قرار بدید.
      توجه2: به جای عدد 777 در کد باید آیدی دسته ای رو قرار بدید که قراره پست هاش noindex,follow بشن.
       
      موفق باشید
    • توسط morteza_a
      با سلام خدمت اساتید
      چند ماهیست که قالب سایت را تغییر داده ام. مشکلی که اخیرا متوجه آن شدن اینست که با ورود تگ جدید، اولا در سایت زمانیکه روی آن تگ کلیک میکنم، با ارور 404 روبرو میشم، بعد از چند روز نیز در وبمستر در لیست Crawl Eror آن تگ با ارور 404 ظاهر میشود. نمونه:
      http://kooshanic.com/siemens-simatic-step7-v5-6/
      در انتهای صفحه چند تگ موجود است، با کلیلک کردن روی هرکدام متوجه مشکل خواهید شد.
      با تشکر
    • توسط sajadshiraz
      با سلام
      چند روز میشه وردپرس من مشکل بهم زده
      روز اول متوجه شدم سایت فقط صفحه اول باز میشه بقیه صفحات ارور 404 میده
      پرسیدم گفتن پیوند یکتا تغییر کرده درستش کردم ولی بازم تغییر کرد
      تو هاست چک کردم دیدم فایل htaccess مشکل داره و مشکلش اینه که بعد از چند ساعت از پاک کردنش دوباره permission از حالت 644 به 444 تغییر پیدا میکنه و حجمش تند تند اضافه میشه و بعد از اینکه حجم زیاد شد دیگه ارور 404 شروع میشه
      با هاست در میان گذاشتم چندین بار ویروس یابی کردن میگن مشکلی نیست
      قالب ها رو کلا حذف کردم
      افزونه ها رو کلا حذف کردم
      بازم این مشکل وجود داره
      خواهشا راهنمایی کنید