• اطلاعیه ها

    • Saeed Fard

      پوشش زنده وردکمپ ۲۰۱۸ اروپا توسط وردپرس پارسی   23/03/97

      اگر کاربر وردپرس هستید حتما تا به حال اسم وردکمپ رو شنیدید، کمپ و دورهمی بزرگ توسعه‌دهنده‌ها و کاربران وردپرس که سالانه در کشورهای مختلف برگزار میشه تحت عنوان وردکمپ هستش که از سمت مراجع اصلی وردپرس حمایت و برگزار می‌شه.   این‌ بار در سال 2018 وردکمپ اروپا در شهر بلگراد کشور صربستان در حال برگزاری هستش، این رویداد طی سه روز 24 تا 26 تیر ماه (June 14-16) برگزار میشه، در این رویداد مصطفی صوفی از وردپرس پارسی و به نمایندگی تمامی کاربران وردپرس فارسی حضور داره. وردپرس پارسی رویداد وردکمپ 2018 اروپا رو به صورت زنده توسط مصطفی پوشش می‌ده و در صورت علاقه‌مندی به این مراسم می‌تونید از طریق وردپرس پارسی دنبالش کنید.در حال حاضر یک روز از این مراسم گذشته که گزارش اون در قسمت پوشش زنده قرار گرفته. برای دنبال کردن مراسم وردکمپ اروپا به صورت لحظه‌ای به صفحه پوشش زنده در قسمت زیر مراجعه کنید. همینطور در آینده منتظر خبر برگزاری اولین وردکمپ در ایران توسط وردپرس‌پارسی باشید. https://wp-parsi.com/wceu-2018

      لینک خبر در وردپرس پارسی : https://wp-parsi.com/wceu-2018-live  
premier

تداخل جی کوئری

9 پست در این موضوع قرار دارد

با سلام

مشکلی که بهش برخورد کردم اینه که

من افزونه ای استفاده میکنم که از jquery 1.8 استفاده میکنه و البته از پیشفرض وردپرس نسخه 3.5.1

ولی الان یک جی کئوری داخل قالبم قرار دادم که این از جی کوئری 1.7 استفاده میکنه

حالا اگر من یکی از آنها را حذف کنم در دیگری تداخل ایجاد میکنه و از کار میوفته و نمیخوام به خاطر لود صفحه هر دو کتابخانه لود بشه چکار کنم؟

0

به اشتراک گذاری این پست


لینک به پست

jquery 1.8 با 1.7 فقط در چند تا سلکتور تفاوت داره احتمالا مشکل از جایی دیگه است

ممکنه یک jquery سومی هم وجود داشته باشه به این مثال دقت کنید

اگر یک فایل open باشه و دستوری برای close و open فایل به صورت toggle وجود داشته باشه و سه فایل جی کوئری اتفاق اینجوری می شه

فایل open با دستور اول close می شه

با دستور دوم open می شه

و دستور سوم close

در نتیجه شما عکس العمل close را می بینید

با حذف یکی

open تبدیل می شه close

و مجددا close به open

و شما هیچ تغییری نمی بینی

این یکی از معمولترین مشکلات کتابخانه جی کوئریه خیلی وقتا جی کوئری سوم داخل افزونه هاست و سخت می شه پیداش کرد ولی می تونید جی کوئری وردپرس رو حذف کنید اگر اون جی کوئری سوم کمتر از 1.4 نباشه مشکلی نخواهید داشت

3

به اشتراک گذاری این پست


لینک به پست

چجوری بدون پلاگین جکوئری وردپرس را حذف کنم؟

0

به اشتراک گذاری این پست


لینک به پست
4

به اشتراک گذاری این پست


لینک به پست

سلام دوباره !

من پیشفرض وردپرس را پاک کردم و بجاش توی هدر


<script src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"></script>

گذاشتم ولی باز یکی از اسلایدر ها م خرابه !

سورس هم که میگیرم فقط کد بالا به عنوان کتابخانه لود میشه نه چیز دیگری بغیر از اون

0

به اشتراک گذاری این پست


لینک به پست

خوب اسلایدرهای که دارید متفاوت هستن و یکی از اینها توابعش احتمالا با نسخه های جدید سازگار نیست برای همین بهم میریزه و خراب میشه

عادی هست!

3

به اشتراک گذاری این پست


لینک به پست

این رو هم تست کنید


<script src="http://code.jquery.com/jquery-1.9.1.js"></script>

2

به اشتراک گذاری این پست


لینک به پست

سلام

همونطوری که در پست اول گفتید بعد از اضافه کردن جی کوئری 1.7 مشکل به وجود اومده و راجع به تجربه شخصی که با این مشکل داشتم (تداخل جی کوئری) میتونم بگم که با آزمون و خطا و پیدا کردن محل مناسبش در قبل و بعد از توابع هدر و فوتر میتونید مشکلو برطرف کنید.

2

به اشتراک گذاری این پست


لینک به پست

سلام

من خودم این مشکل رو داشتم

ی افزونه نصب کردم و تنها کاری که بعدش کردم این بود که فعالش کردم!!خودم خیلی متعجب شدم که یی هو دیدم همش درست شد

http://wordpress.org/extend/plugins/wp-jquery-cdn/

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری