Bahram

آموزش افزایش بیشترین اندازه پرونده برای بارگذاری در وردپرس

14 پست در این موضوع قرار دارد

سلام دوستان

چطور میتونم بیشترین میزان حجم پرونده برای آپلود یا بارگزاری فایل در وردپرس رو ایجاد کنم مثلا 10 گیگ

کمک کنید ؟؟؟؟ حیلی مهمه

0

به اشتراک گذاری این پست


لینک به پست

راه اول ، فايل functions.php ، قبل از <? اضافه بشه ..


@ini_set( 'upload_max_size' , '64M' );
@ini_set( 'post_max_size', '64M');
@ini_set( 'max_execution_time', '400' );

در اين كد بيشترين مقدار 64 مگابايت تنظيم شده و مدت اعتبار براي انجام كار 400 كه با خطلا مواجه نشيد ، اگه مقدار رو بيشتر ميكنيد مقدار زمان رو هم بيشتر كنيد ..

راه دوم : htaccess

به انتهاي htaccess اضافه بشه ..


php_value upload_max_filesize 64M
php_value post_max_size 64M
php_value max_execution_time 400
php_value max_input_time 400

راه سوم : php.ini


upload_max_filesize = 64M
post_max_size = 64M
max_execution_time = 400

اگه هاستتون اشتراكي نباشه اين كد‌ها جواب ميده ، در غير اين صورت بايد با پشتيباني سرورتون تماس بگيريد ..

موفق باشيد ../.

12

به اشتراک گذاری این پست


لینک به پست

سلام ممنون بابت راهنمای اما ممنون می شم یکم بییشتر تو ضیح بدید مثل این سه راه را که گفتید یکی شون اجرا کنیم کافیه ؟

و دمین سوال داشتم برای اینکه به پوشه راه سوم : php.ini بریم باید ابتدا از کجا وارد شویم ؟؟؟

0

به اشتراک گذاری این پست


لینک به پست

سلام

بله هرکدوم رو انجام بدید کافیه.

در مورد php.ini هم این فایل رو بسازید و کدهای بالا رو توش قرار بدید و در پوشه wp-admin قرار بدید.

5

به اشتراک گذاری این پست


لینک به پست

سلام من همین کارا را کردم ولی نشد

با پشتیبانی هاستم تماس گرفتم که گفتند

""این مورد مشکل از سمت cms شماست سرور تا 64 مگا را برای شما ازاد قرار داده است

""

0

به اشتراک گذاری این پست


لینک به پست

از مدیر هاستتون درخواست کنین که مقدارش رو براتون افزایش بدن، راه مطمئن‌تریه.

3

به اشتراک گذاری این پست


لینک به پست

راه سوم بهترینه البته اگر سرور اجازه استفاده از php.ini شخصی به شما بده. در هر صورت مدیر هاست شما باید براتون درستش کنه.

2

به اشتراک گذاری این پست


لینک به پست

يك سوال

آيا ميشه اين مقدار را فقط براي كاربران سايتمون تعريف كنيم؟

1

به اشتراک گذاری این پست


لینک به پست

اگر ای پی ثابت دارید(که فکر نمیکنم) میشه توی فایل مورد نظر (نه php.ini) اعمال کرد.

اما همه اینها برای کل کاربرها اعمال میشن.

اما در ادرس زیر یک تابع برای محدودیت اپلود برای کاربران نوشته شده(تست نشده)

http://wordpress.stackexchange.com/questions/47580/give-users-a-maximum-upload-capacity-limit-the-number-of-files-a-user-can-uploa

2

به اشتراک گذاری این پست


لینک به پست

بنده هم هر 3 راه رو جداگانه تست کردم نشد

_ از کجا باید فهمید هاست اشتراکیه یا نه؟

_و اینکه من از Cpanel حجمهای زیادی میتونم آپلود کنم اما حجم وردپرسم 1مگ هست.

لطفا راهنمایی کنید

ضمنا از وردپرس شبکه استفاده میکنم

ویرایش شده در توسط .Ibrahim
0

به اشتراک گذاری این پست


لینک به پست

بنده هم هر 3 راه رو جداگانه تست کردم نشد

_ از کجا باید فهمید هاست اشتراکیه یا نه؟

_و اینکه من از Cpanel حجمهای زیادی میتونم آپلود کنم اما حجم وردپرسم 1مگ هست.

لطفا راهنمایی کنید

ضمنا از وردپرس شبکه استفاده میکنم

این کد ها نباید مشکلی داشته باشن.

به مدیریت هاستتون بگید براتون درستش کنن.

هاست شما اشتراکیس.

منظور دوستمون اون بالا این بود که حجم یک گیگ توی هاست اشتراکی جواب نمیده چون از طرف هاستینگ محدود میشه.

2

به اشتراک گذاری این پست


لینک به پست

کاری ندارم که مشکل دوست عزیز Bahram حل شده باشه یا نه.

می خوام در مورد پشتیبانی هاست و سرور بگم.

اگه مشکلی در رابطه با سیستم مدیریت محتواتون داشته باشید اگه به پشتیبانی هاست بگید مطمئنم که همشون می گن مشکل از سیستم مدیریت محتوای سایت هست. چون من خودم این تجربه رو داشتم.

پس باید مشکلتون رو در انجمن های پشتیبانی این سیستم ها مطرح کنید مطمئن باشید که بهتر می تونن کمکتون کنن.

اگه درست می گم تشکر رو بزنید اگه هم درست نمی گم تشکر رو نزنید.

خدانگهدار :D:lol::P

ویرایش شده در توسط Ghaem Omidi
6

به اشتراک گذاری این پست


لینک به پست

راه اول ، فايل functions.php ، قبل از <? اضافه بشه ..


@ini_set( 'upload_max_size' , '64M' );
@ini_set( 'post_max_size', '64M');
@ini_set( 'max_execution_time', '400' );

در اين كد بيشترين مقدار 64 مگابايت تنظيم شده و مدت اعتبار براي انجام كار 400 كه با خطلا مواجه نشيد ، اگه مقدار رو بيشتر ميكنيد مقدار زمان رو هم بيشتر كنيد ..

راه دوم : htaccess

به انتهاي htaccess اضافه بشه ..


php_value upload_max_filesize 64M
php_value post_max_size 64M
php_value max_execution_time 400
php_value max_input_time 400

راه سوم : php.ini


upload_max_filesize = 64M
post_max_size = 64M
max_execution_time = 400

اگه هاستتون اشتراكي نباشه اين كد‌ها جواب ميده ، در غير اين صورت بايد با پشتيباني سرورتون تماس بگيريد ..

موفق باشيد ../.

سلام دوست عزیز

خسته نباشین

من اول روش فانکشن رو تست کردم و اولش بعد از

<?php

این کد رو نوشتم

@ini_set( 'upload_max_size' , '100M' );

@ini_set( 'post_max_size', '100M');

@ini_set( 'max_execution_time', '1000' );

ولی هیچ فرقی نکرد

بعدشم رفتم تو روت سایت و فایل htacces رو آوردم و آخرش اون کد شما رو اضافه کردم

ولی سایت کلا از دسترس خارج شد تا برش گردوندم

خواستم ببینم من اشتباه کردم یا این دستورات رو سی ام اس ما جواب نمیدن ؟

ممنون از لطفتون

0

به اشتراک گذاری این پست


لینک به پست

اگرجواب ندادن باید از سمت سرور اقدام بشه

به مدیر سرور بگید تا افزایش بده

2

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط ghasem47
      سلام به همه ی دوستان عزیز
      من در نظر دارم که یک وبسایت برای فروش فایل هایی مربوط به وب راه اندازی کنم .و قصد من این است که علاوه بر فروش فایل در سایت ، هاست و دامنه نیز بفروشم . و همچنین این هم مهمه که کاربر برای خرید هاست و یا دامین باید در وبسایت عضو بشه و بعد از خرید نیز بتونه اطلاعات هاست و تنظیمات هاست رو از حساب کاربریش در وبسایت من انجام بده.
      مانند این وبسایت : (سایت ساز زرین )   https://sitesazz.ir/
      اما تنها مشکل و مسئله در این جاست که من نمی دونم و بلد نیستم که باید چگونه این کار رو انجام بدم؟
      من قراره که وبسایت رو با وردپرس راه اندازی کنم ولی نمی دونم چطوری باید این امکان فروش هاست رو به وبسایت اضافه کنم و کاری کنم که در وبسایت بتونم هاست و دامنه هم بفروشم و به علاوه این مسئله هم هست که باید کاربرا بتونن از حساب کاربری داخل وبسایتشون به تنظیمات هاست و یا دامنشون دسترسی پیدا کنند.
      لطفاً منو راهنمایی کنید.
      با تشکر
    • توسط iranibonsai
      درود، سایتی رو با وردپرس بالا آوردیم
      اما اکنون در صفحات داخلی سایت کد خطایی رو در بخش بالای مرورگر نشون میده که نتونستیم رفعش کنیم
      Warning: count(): Parameter must be an array or an object that implements Countable in /home3/zahrefzo/public_html/wp-includes/post-template.php on line 284
      این خطا قبلا وجود نداشت، نفهمیدم به چه علتی بوجود آمده و تو اینترنت هم چیز خاصی راجعبه رفعش پیدا نکردم، ممنون میشم اعلام نظر بفرمایید
      آدرس سایت :
      http://minelbeautysalon.com//
    • توسط sydvza
      باسلام ببخشید من کلیدواژه دکه را انتخاب کردم ولی در سرچ گوگل کلمه دکه وارد میکنم حتی جز 10 صفحه هم نیستم
      https://dackeh.com
    • توسط MajidRB
      سلام وقتتون بخیر.
      دوستان قالب placid رو به صورت های مختلف دانلود و نصب کردم ( هم از سایت های فارسی و قالب فارسی شده هم از منابع خود وردپرس)
      چه به شکل فارسی چه به شکل انگلیسی پست ها رو اونطوری که در پیش نمایش قالب نشان داده شده ، در صفحه اصلی نشان نمیده !
      عکس ها رو درج میکنم
      هیچ تنظیماتی نمانده که من دستکاری نکرده باشم
      فکر کنم باید چند خط کد کم یا زیاد بشه ( که بلد نیستم ! )
      خیلی ممنون میشم راهنمایی کنید
       


    • توسط nnmmss
      با سلام
       
      من اصلا وردپرس بلد نيستم ولي مجبورم كه سايتي را نگهداري كنم. در اين سايت وقتي وارد بعضي صفحات ميشوم عبارت "دسته" به انتهاي عنوان اضافه شده.  اين صفحات بعنوان "دسته" در فهرست انتخاب شده اند. مثلا
      من در منو مورد 
      آرشيو   
      را دارم كه زير مجموعه آن 
      آرشيو سال 97
      آرشيو سال 96
      آرشيو سال 95
      هست.
       
      من "آرشيو" بعنوان برگه انتخاب شده و آرشيو سال 97 - 96 - 95 به صورت دسته انتخاب شده است. وقتي من روي هر كدام از آرشيو سال 97 يا 96 يا ..... ميروم عنوان صفحه به صورت زير است
      آرشیو سال 97دسته
      اين عبارت دسته از كجا ميايد؟ و من چگونه ميتوانم آنرا حذف كنم؟
      با تشكر