roode

مشکل با افزنه‌های postviews و popular posts

13 پست در این موضوع قرار دارد

آقا حدود یه ماهی هست که یه مشکل با این افزونه و همچنین wp-postviews پیدا کرده سایتم که هر کاری کردم و هر چی سرچ کردم نتونستم درستش کنم.

متاسفانه این دو افزونه، از یه ماه پیش فقط بازدیدهای افراد لاگین کرده رو می‌شمارن و مثلا به جای اینکه پستی چند صد بازدید داشته باشه، کمتر از ۱۰ بازدید داره و این مسئله در مورد همه پستها صدق می کنه؛ در حالی که تنظیمات افزونه ها درسته و طوری تنظیم شده که همه رو بشماره.

اگه کمکی میکنه، اینم بگم که یه ماه پیش، کدی که توی صفحه اصلی و داخل پستها میزان بازدید رو نشون میداد (برای هر دو افزونه) حذف کردم تا کاربران میزان بازدید رو نبینن؛ اما از اون زمان این مشکل پیش اومد؛ چون به هر حال اولا خودم میخوام از پنل مدیریت، میزان بازدیدها رو بدونم و ثانیا افزونه popular posts باید درست بشماره تا بتونه پربازدیدترین‌های هفته و ماه رو که توی صفحه اصلی استفاده می‌کنم درست نشون بده و به خاطر این مشکل، درست نشون نمیده و بر اساس همون کمتر از ۱۰تا بازدید لاگین کرده‌ها نشون میده

در ضمن کد wp-head توی هدر قالب هست و با توجه به اینکه بازدیدهای لاگین کرده‌ها رو میشماره، فکر نمی‌کنم مشکل از این باشه

لطفا یه کمکی به من بکنید، گیج شدم و اعصابم رو هم خرد کرده

ممنون

به اشتراک گذاری این پست


لینک به پست

دوست عزیز افزونه post view شما باید برین توی تنظیمات افزونه و گزینه Count Views From: رو به Everyone تغییر بدین درست میشه.

فکر میکنم تا وقتی که کد افزونه توی پست فراخوانی نشه بازدید ها ثبت نمیشن درون افزونه post view

ویرایش شده در توسط ashkanreal

به اشتراک گذاری این پست


لینک به پست

همون طور که گفتم تنظیمات درسته و روی Everyone هست (دو سال هست که همین طور هست و دست بهش نزدم و بازم چک کردم و درسته)

به اشتراک گذاری این پست


لینک به پست

شما حالا کد رو بزارین و دوباره امتحان کنید ببینید جواب میده یا نه؟

به اشتراک گذاری این پست


لینک به پست

popular posts گزارش خطا زیاد داره

پیشنهاد می کنم با حذفش چک کنید

postview یک خروجی برای preview داره و یکی read که منظورش ورودی های تازه و کاربران و ربات های دائمی است شاید با جابجایی آیتم مشکل برطرف بشه

به اشتراک گذاری این پست


لینک به پست

فعلا که popular posts برام مهمتره و postviews رو کلا حذف کردم

popular posts رو هم یک بار کل فایلهاش و کش افزونه رو از هاست حذف کردم و دوباره نصب کردم،‌ اما باز هم همون مشکل رو دارم

به اشتراک گذاری این پست


لینک به پست

خوب شما افزونه مشکل دار را نگه داشتید افزونه سالم رو حذف کردید

معمولا مشکلات از اسکریپت ها و افزونه هایی به وجود می آد که امکاناتشون خیلی بدرد خوره

چون با توجه به اینکه نمونه های رایگان ازشون یا کمه یا نیست و قطعا کاربر پسند خواهد شد به سرعت همه گیر می شوند اما بعضی وقتها چند برابر هزینه خرید نمونه فروشی اون اسکریپت از ترافیک و فضای هاست باید براشون هزینه کرد

البته منظورم کلاهبرداری و سرقت نیست

اینگونه اسکریپت ها را معمولا در مراحل تست رایگان می کنند و وقتی رفع ایراد کامل شد با یک رنگ و لعاب چشمگیرتر می فروشند

در مورد افزونه شما مطمئن نیستم ولی اگر در انجمن جستجو کنید چندین مورد گزارش مشکل ازش بوده

به اشتراک گذاری این پست


لینک به پست

من هر چی جستجو کردم، ندیدم کسی مشکل مشابهی داشته باشه و راهکاری برای این مسئله ارائه شده باشه

به اشتراک گذاری این پست


لینک به پست

افزونه امنیتی یا افزونه ایی در مورد کاربران نصب دارید؟

به اشتراک گذاری این پست


لینک به پست

نخیر جناب مرتضی؛

البته بالاخره خودم مشکل رو حل کردم

برای کسانی که ممکنه بعدا این مشکل براشون پیش بیاد:

اونهایی که از هیچ افزونه‌ای برای کش استفاده نمی‌کنن، گزینه Ajaxify رو از تنظیمات این افزونه غیر فعال کنند تا مشکل حل بشه و شروع به شمارش بکنه

البته واسه postviews فعلا راهکاری پیدا نکردم و همون مشکل رو دارم اما دیگه از این افزونه استفاده نمیکنم

به اشتراک گذاری این پست


لینک به پست

دوست عزیز شما باید کد نمایش بازدید رو توی سایت قرار بدین تا بتونه تعداد بازدید ها رو بشماره.

به اشتراک گذاری این پست


لینک به پست

ممنون اشکان جان

اگه خواستم از postviews استفاده کنم، این گفته‌ت رو امتحان می کنم و به کار میگیرم

به اشتراک گذاری این پست


لینک به پست

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • مطالب مشابه

    • توسط mahdi021
      سلام
      خسته نباشید
      من یوزر و پسورد رو میزنم ولی وقتی میزنم لوگین صفحه رفرش میشه باز همین صفحه میاد بدون هیچ اخطاری
      البته من دیروز ی افزونه امنیتی نصب کردم و ادرس صفحه لوگین رو هم عوض کردم
      ولی دیروز مشکلی نداشت از امروز اینجوری شده
      لطفا کمکم کنید
    • توسط hiwa
      سلام دوستان
      یک مشکل خاصی 1-2 هفته است من رو بدون گرفتن نتیجه به خودش مشغول کرده (با کلی استرس و اعصاب خوردی). الان به ذهنم رسید که مشکل رو اینجا مطرح کنم شاید کسی بتونه کمکم کنه. حتی اگه هزینه ای مطالبه باهاش واقعا ممنونتون میشم.
      من در یک سایت آگهی (لینک) که از افزونه wp job manager و افزونه های مکمل این افزونه برای ساخت این سایت استفاده کرده ام (قالب listify).
      سایت به خوبی کار میکرد تا اینکه مجبور شدم سایت رو به کمک polylang دو زبانه کنم (توسعه دهنده قالب این افزونه رو توصیه کرده: لینک)
      پس از نصب این افزونه، فایل mo افزونه job manager دیگه لود نمیشه. یعنی بخشهایی از سایت که مربوط به این افزونه است، انگلیسی میشه (این صفحه سایت، وقتی polylang غیرفعال باشه کاملا فارسیه اما وقتی فعال باشه به این صورت نمایش داده میشه یعنی ترکیبی از فارسی و انگلیسی)
      با غیر فعال کردن polylang مشکل رفع میشه
      اما من باید سایت رو دو زبانه کنم. پس مجبورم از polylang استفاده کنم.
      آیا راهی وجود داره که بدون استفاده از فایل po بخشهایی که مربوط به این افزونه job manager هست رو فارسی کنم؟
      ممنون میشم هر راه حل و سرنخی به ذهنت میرسه رو بهم بگید
      زیاد سرچ کردم. بقیه هم این مشکل رو با ترکیب این دو افزونه دارند(لینک) اما راه حلی که واسه من موثر باشه رو پیشنهاد نکرده ان.
       
    • توسط majidted
      سلام  خسته نباشید بسیار ، به مشکلی خوردم و درخواست کمک هر کسی میتونه کمک کنه ، اینم شمارمه 09300151579 درصورت نیاز تماس بگیرید

      مشکل ما اینه که ما وقتی میخوایم داخل فایل htaccess از کد
      RewriteEngine On RewriteCond %{HTTP:X-Forwarded-Proto} !https RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L] استفاده کنیم ، (کدی که اجبار به استفاده از HTTPS ) میکنه این ارور رو میده : the page isn't redirecting properly

       
      اینم فایل htaccess من

      خیلی لطف میکنید اگر کمکم کنید ،
      htaccess.txt
    • توسط zodiac
      سلام و خسته نباشید خدمت تمامی عزیزان
      من حدودا یه ماهی میشه که به جمع کاربران ورد پرس وارد شدم ولی مشکل جدی در پست گذاشتن به زبان فارسی دارم و وقتی که پست میزارم نام پست، متن پست، نام دسته به علامت سوال«؟» تبدیل میشه
      لطفا راهنمایی کنین که چجوری مشکل رو حل کنم
      زبان خوده وردپرس فارسی ـیه و مشکلی نداره
      البته در سایت به صورت تکه تکه نوشته شده است
      خیلی ممنون
      آدرس سایت: 
      ic.xzn.ir/zodiac
    • توسط zodiac
      سلام و خسته نباشید خدمت تمامی عزیزان
      من حدودا یه ماهی میشه که به جمع کاربران ورد پرس وارد شدم ولی مشکل جدی در پست گذاشتن به زبان فارسی دارم و وقتی که پست میزارم نام پست، متن پست، نام دسته به علامت سوال«؟» تبدیل میشه
      لطفا راهنمایی کنین که چجوری مشکل رو حل کنم
      زبان خوده وردپرس فارسی ـیه و مشکلی نداره
      البته در سایت به صورت تکه تکه نوشته شده است
      خیلی ممنون
      آدرس سایت: 
      ic.xzn.ir/zodiac